summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2009-03-12 02:52:38 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2009-03-12 02:52:38 +0000
commit7da0e77f3dd31970f7e740bd9968f5b821a2985a (patch)
tree58dda6bf6e05bda1ce06d1719972a55d1b8b911a /kde-base/kalzium
parenttypo (diff)
downloadgentoo-2-7da0e77f3dd31970f7e740bd9968f5b821a2985a.tar.gz
gentoo-2-7da0e77f3dd31970f7e740bd9968f5b821a2985a.tar.bz2
gentoo-2-7da0e77f3dd31970f7e740bd9968f5b821a2985a.zip
Fixed build time bug 261392.
(Portage version: 2.2_rc24/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog6
-rw-r--r--kde-base/kalzium/files/kalzium-4.2.1-include-order.patch26
-rw-r--r--kde-base/kalzium/kalzium-4.2.1.ebuild16
3 files changed, 38 insertions, 10 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index c327e6924f71..92e8358600e4 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.114 2009/03/08 18:58:15 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.115 2009/03/12 02:52:37 cryos Exp $
+
+ 12 Mar 2009; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/kalzium-4.2.1-include-order.patch, kalzium-4.2.1.ebuild:
+ Fixed build time bug 261392.
08 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> -kalzium-4.2.0.ebuild:
Drop KDE 4.2.0
diff --git a/kde-base/kalzium/files/kalzium-4.2.1-include-order.patch b/kde-base/kalzium/files/kalzium-4.2.1-include-order.patch
new file mode 100644
index 000000000000..1faffa2e3812
--- /dev/null
+++ b/kde-base/kalzium/files/kalzium-4.2.1-include-order.patch
@@ -0,0 +1,26 @@
+--- kalzium-4.2.1/work/kalzium-4.2.1/kalzium/libavogadro-kalzium/src/CMakeLists.txt 2009-02-26 09:17:16.000000000 -0500
++++ /root/CMakeLists.txt 2009-03-11 18:19:48.000000000 -0400
+@@ -15,10 +15,12 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ )
+
+-include(${QT_USE_FILE})
++# Ensure the Avogadro include directory is always first
++get_directory_property(tmp_include_dirs INCLUDE_DIRECTORIES)
++set_directory_properties(PROPERTIES INCLUDE_DIRECTORIES
++ "${libavogadro-kalzium_SOURCE_DIR}/include;${tmp_include_dirs}")
+
+ include_directories(
+- ${libavogadro-kalzium_SOURCE_DIR}/include
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/..
+@@ -26,6 +28,8 @@
+ ${EIGEN_INCLUDE_DIR}
+ )
+
++include(${QT_USE_FILE})
++
+ # Need to build with visibility enabled if KDE is
+ if(__KDE_HAVE_GCC_VISIBILITY)
+ add_definitions(-DHAVE_GCC_VISIBILITY)
diff --git a/kde-base/kalzium/kalzium-4.2.1.ebuild b/kde-base/kalzium/kalzium-4.2.1.ebuild
index 8e7238407b95..4457e0a6b688 100644
--- a/kde-base/kalzium/kalzium-4.2.1.ebuild
+++ b/kde-base/kalzium/kalzium-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.2.1.ebuild,v 1.2 2009/03/08 13:11:54 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.2.1.ebuild,v 1.3 2009/03/12 02:52:37 cryos Exp $
EAPI="2"
@@ -13,20 +13,18 @@ DESCRIPTION="KDE: periodic table of the elements."
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="editor debug +plasma solver"
-DEPEND="
- >=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
editor? (
>=dev-cpp/eigen-1.0.5
>=sci-chemistry/openbabel-2.2
)
- solver? ( dev-ml/facile[ocamlopt] )
-"
+ solver? ( dev-ml/facile[ocamlopt] )"
RDEPEND="${RDEPEND}"
-KMEXTRACTONLY="
- libkdeedu/kdeeduui/
- libkdeedu/libscience/
-"
+KMEXTRACTONLY=" libkdeedu/kdeeduui/
+ libkdeedu/libscience/"
+
+PATCHES=( "${FILESDIR}/${P}-include-order.patch" )
src_configure(){
mycmakeargs="${mycmakeargs}