summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commita4c1d03d518d1416c826bb73ad524dc9bf1702a5 (patch)
treed6a50377f609e5e7550ca8a99686adcdcbdbd7a1 /kde-base/kalzium
parentRemoved unneccessary python_copy_sources (diff)
downloadgentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.gz
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.bz2
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.zip
[kde-base] Add KDE SC 4.6.1
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.6.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index f7a2bbaa3ef6..e10fdb71d9d1 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.180 2011/01/26 20:29:19 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.181 2011/03/04 18:00:20 alexxy Exp $
+
+*kalzium-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*kalzium-4.6.0 (26 Jan 2011)
diff --git a/kde-base/kalzium/kalzium-4.6.1.ebuild b/kde-base/kalzium/kalzium-4.6.1.ebuild
new file mode 100644
index 000000000000..145d6f0e78b1
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.6.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.6.1.ebuild,v 1.1 2011/03/04 18:00:20 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-meta_src_configure
+}