summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 20:38:12 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 20:38:12 +0000
commit14483f4039a592ee065bff28c256013cf6e69b76 (patch)
treec4cb2be8cfee91d8788461afdf0036d42b20d92c /kde-base/kate
parentVersion bump KDE 4.3.3 (diff)
downloadgentoo-2-14483f4039a592ee065bff28c256013cf6e69b76.tar.gz
gentoo-2-14483f4039a592ee065bff28c256013cf6e69b76.tar.bz2
gentoo-2-14483f4039a592ee065bff28c256013cf6e69b76.zip
Version bump KDE 4.3.3
(Portage version: 2.2_rc48/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.3.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 6709718bdbf8..1ba4d6cdb410 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.149 2009/10/18 13:50:07 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.150 2009/11/02 20:38:12 wired Exp $
+
+*kate-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +kate-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> kate-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/kate/kate-4.3.3.ebuild b/kde-base/kate/kate-4.3.3.ebuild
new file mode 100644
index 000000000000..dde9593ca967
--- /dev/null
+++ b/kde-base/kate/kate-4.3.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.3.3.ebuild,v 1.1 2009/11/02 20:38:12 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}