summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
committerJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
commit2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51 (patch)
tree733e9e1acf77d4f47af78826e93c8cf4d670bf27 /kde-base/kate
parentFix LICENSE, bug 447390. (diff)
downloadgentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.gz
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.bz2
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.zip
Version bump KDE SC 4.10.3.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, RepoMan options: --include-arches="amd64", signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.10.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index f5acd731f50d..1e7658e2426f 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.274 2013/05/05 11:50:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.275 2013/05/06 20:18:29 johu Exp $
+
+*kate-4.10.3 (06 May 2013)
+
+ 06 May 2013; Johannes Huber <johu@gentoo.org> +kate-4.10.3.ebuild:
+ Version bump KDE SC 4.10.3
05 May 2013; Agostino Sarubbo <ago@gentoo.org> -kate-4.10.1.ebuild:
Remove old
diff --git a/kde-base/kate/kate-4.10.3.ebuild b/kde-base/kate/kate-4.10.3.ebuild
new file mode 100644
index 000000000000..0fb0aeb85dfd
--- /dev/null
+++ b/kde-base/kate/kate-4.10.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.10.3.ebuild,v 1.1 2013/05/06 20:18:29 johu Exp $
+
+EAPI=5
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+PYTHON_COMPAT=( python{2_7,3_1,3_2} )
+
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma python"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ python? ( $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" 4.9.2-r1) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build python pate)
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}