summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:20:31 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:20:31 +0000
commitb0de4739638bf409c7df1780cd43596a80b7f385 (patch)
treee0c53627ba269d1ec76fb63e80961489ce45b031 /kde-base/kate
parent[kde-base/kmail] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-b0de4739638bf409c7df1780cd43596a80b7f385.tar.gz
gentoo-2-b0de4739638bf409c7df1780cd43596a80b7f385.tar.bz2
gentoo-2-b0de4739638bf409c7df1780cd43596a80b7f385.zip
[kde-base/kate] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.4.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 24f6c9e943e1..4eb87a0d177a 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.165 2010/01/25 14:32:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.166 2010/02/09 00:20:31 alexxy Exp $
+
+*kate-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*kate-4.3.5 (25 Jan 2010)
diff --git a/kde-base/kate/kate-4.4.0.ebuild b/kde-base/kate/kate-4.4.0.ebuild
new file mode 100644
index 000000000000..687444ed0aa3
--- /dev/null
+++ b/kde-base/kate/kate-4.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.4.0.ebuild,v 1.1 2010/02/09 00:20:31 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}