summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commitdcee7201ef2606358a4f2abc45af713ef2555e5a (patch)
treedac1ea20988f395333c20c4985b60f84f2e71a82 /kde-base/kate
parentbump to the TeX Live 2011 version (diff)
downloadgentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.gz
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.bz2
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.zip
[kde-base] Version bump KDE SC 4.7.0
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.7.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 1990d40561c7..934908708dde 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.202 2011/07/09 15:14:14 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.203 2011/07/27 14:04:43 alexxy Exp $
+
+*kate-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*kate-4.6.5 (09 Jul 2011)
diff --git a/kde-base/kate/kate-4.7.0.ebuild b/kde-base/kate/kate-4.7.0.ebuild
new file mode 100644
index 000000000000..29bbf9ab7b0a
--- /dev/null
+++ b/kde-base/kate/kate-4.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.7.0.ebuild,v 1.1 2011/07/27 14:04:43 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+KDE_SCM="git"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}