summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-14 18:01:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-14 18:01:33 +0000
commite07ea6c227e759232b932a5b63a74140ddd6a921 (patch)
tree15c3b9f2737b8df09e845616bdf7a7864b66f961 /kde-base/kate
parentLink libeap with -lssl (#158062). (diff)
downloadgentoo-2-e07ea6c227e759232b932a5b63a74140ddd6a921.tar.gz
gentoo-2-e07ea6c227e759232b932a5b63a74140ddd6a921.tar.bz2
gentoo-2-e07ea6c227e759232b932a5b63a74140ddd6a921.zip
Add patch to fix issues with hidden visibility disabled, bug #158146. Thanks Timothy for reporting.
(Portage version: 2.1.2_rc3-r4)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog9
-rw-r--r--kde-base/kate/files/digest-kate-3.5.5-r13
-rw-r--r--kde-base/kate/files/kate-3.5.5-visibility.patch77
-rw-r--r--kde-base/kate/kate-3.5.5-r1.ebuild16
4 files changed, 104 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 1300abe2f7f5..7f54487ecea4 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.64 2006/12/11 11:45:41 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.65 2006/12/14 18:01:33 flameeyes Exp $
+
+*kate-3.5.5-r1 (14 Dec 2006)
+
+ 14 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kate-3.5.5-visibility.patch, +kate-3.5.5-r1.ebuild:
+ Add patch to fix issues with hidden visibility disabled, bug #158146. Thanks
+ Timothy for reporting.
11 Dec 2006; <kloeri@gentoo.org> kate-3.5.5.ebuild:
Stable on ia64.
diff --git a/kde-base/kate/files/digest-kate-3.5.5-r1 b/kde-base/kate/files/digest-kate-3.5.5-r1
new file mode 100644
index 000000000000..155559e1a388
--- /dev/null
+++ b/kde-base/kate/files/digest-kate-3.5.5-r1
@@ -0,0 +1,3 @@
+MD5 0c685af1cbca75f9c77b3ed231ba0468 kdebase-3.5.5.tar.bz2 23851886
+RMD160 6cf804de0487347a3e1d4ea6e5ba5114d23d9806 kdebase-3.5.5.tar.bz2 23851886
+SHA256 f77632e44214648e2d0adfe1a79dd61a6a738c21fe5abb0baff16b72432baaa0 kdebase-3.5.5.tar.bz2 23851886
diff --git a/kde-base/kate/files/kate-3.5.5-visibility.patch b/kde-base/kate/files/kate-3.5.5-visibility.patch
new file mode 100644
index 000000000000..4468a30ffff6
--- /dev/null
+++ b/kde-base/kate/files/kate-3.5.5-visibility.patch
@@ -0,0 +1,77 @@
+SVN commit 599194 by dhaumann:
+
+fix missing KDE_EXPORTs which caused undefined references for kate plugins.
+
+CCMAIL: kwrite-devel@kde.org
+
+
+ M +1 -1 application.h
+ M +1 -1 documentmanager.h
+ M +2 -2 plugin.h
+ M +1 -1 pluginconfiginterface.h
+ M +1 -1 pluginconfiginterfaceextension.h
+
+
+--- branches/KDE/3.5/kdebase/kate/interfaces/application.h #599193:599194
+@@ -72,7 +72,7 @@
+ * Returns the application object
+ * @return Application application object
+ */
+-Application *application ();
++KDE_EXPORT Application *application ();
+
+ }
+
+--- branches/KDE/3.5/kdebase/kate/interfaces/documentmanager.h #599193:599194
+@@ -104,7 +104,7 @@
+ * Returns the document manager object
+ * @return DocumentManager document manager object
+ */
+-DocumentManager *documentManager ();
++KDE_EXPORT DocumentManager *documentManager ();
+
+ }
+
+--- branches/KDE/3.5/kdebase/kate/interfaces/plugin.h #599193:599194
+@@ -52,7 +52,7 @@
+ unsigned int myPluginNumber;
+ };
+
+-Plugin *createPlugin ( const char* libname, Application *application = 0, const char *name = 0,const QStringList &args = QStringList() );
++KDE_EXPORT Plugin *createPlugin ( const char* libname, Application *application = 0, const char *name = 0,const QStringList &args = QStringList() );
+
+ /*
+ * view plugin class
+@@ -80,7 +80,7 @@
+ unsigned int myPluginViewInterfaceNumber;
+ };
+
+-PluginViewInterface *pluginViewInterface (Plugin *plugin);
++KDE_EXPORT PluginViewInterface *pluginViewInterface (Plugin *plugin);
+
+ }
+
+--- branches/KDE/3.5/kdebase/kate/interfaces/pluginconfiginterface.h #599193:599194
+@@ -56,7 +56,7 @@
+ };
+
+ class Plugin;
+-PluginConfigInterface *pluginConfigInterface (Plugin *plugin);
++KDE_EXPORT PluginConfigInterface *pluginConfigInterface (Plugin *plugin);
+
+ }
+
+--- branches/KDE/3.5/kdebase/kate/interfaces/pluginconfiginterfaceextension.h #599193:599194
+@@ -97,7 +97,7 @@
+ };
+
+ class Plugin;
+-PluginConfigInterfaceExtension *pluginConfigInterfaceExtension (Plugin *plugin);
++KDE_EXPORT PluginConfigInterfaceExtension *pluginConfigInterfaceExtension (Plugin *plugin);
+
+ }
+
+_______________________________________________
+KWrite-Devel mailing list
+KWrite-Devel@kde.org
+https://mail.kde.org/mailman/listinfo/kwrite-devel \ No newline at end of file
diff --git a/kde-base/kate/kate-3.5.5-r1.ebuild b/kde-base/kate/kate-3.5.5-r1.ebuild
new file mode 100644
index 000000000000..157c05cf2f48
--- /dev/null
+++ b/kde-base/kate/kate-3.5.5-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-3.5.5-r1.ebuild,v 1.1 2006/12/14 18:01:33 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE MDI editor/ide"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility"
+
+KMEXTRA="doc/kwrite"
+
+PATCHES="${FILESDIR}/${P}-visibility.patch"