summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:11:53 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:11:53 +0000
commit7a9e2dd14181056484126e752922e501480eb615 (patch)
tree9178aa03ef67f7708a8d2886d386a34f54cadd48 /kde-base/kcalc/kcalc-4.0.5.ebuild
parentAdded the KDE 4.0.5 version of kcachegrind. (diff)
downloadgentoo-2-7a9e2dd14181056484126e752922e501480eb615.tar.gz
gentoo-2-7a9e2dd14181056484126e752922e501480eb615.tar.bz2
gentoo-2-7a9e2dd14181056484126e752922e501480eb615.zip
Added the KDE 4.0.5 version of kcalc.
(Portage version: 2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'kde-base/kcalc/kcalc-4.0.5.ebuild')
-rw-r--r--kde-base/kcalc/kcalc-4.0.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/kcalc/kcalc-4.0.5.ebuild b/kde-base/kcalc/kcalc-4.0.5.ebuild
new file mode 100644
index 000000000000..2eb7e67a4e93
--- /dev/null
+++ b/kde-base/kcalc/kcalc-4.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/kcalc-4.0.5.ebuild,v 1.1 2008/06/05 21:11:53 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdeutils
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE calculator"
+KEYWORDS="~amd64 ~x86"
+IUSE="${IUSE} debug htmlhandbook"
+
+DEPEND="dev-libs/gmp"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ pushd "${WORKDIR}"/${PN}_build/kcalc/knumber/tests > /dev/null
+ emake knumbertest && \
+ ./knumbertest.shell || die "Tests failed."
+ popd > /dev/null
+}