summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commitb0b482a63f92c732c21a7a05f6e91ed9d13d91e6 (patch)
tree5874d7078782459c535f58fd83e3acaff5ea7f72 /kde-base/kde-l10n
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadgentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.gz
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.bz2
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.zip
[kde-base] Add KDE SC 4.5.4
(Portage version: 2.2.0_alpha6_p10/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.5.4.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 80724883f266..f7e6e0b5901c 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.75 2010/11/03 16:50:39 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.76 2010/12/02 21:14:30 alexxy Exp $
+
+*kde-l10n-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +kde-l10n-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*kde-l10n-4.5.3 (03 Nov 2010)
diff --git a/kde-base/kde-l10n/kde-l10n-4.5.4.ebuild b/kde-base/kde-l10n/kde-l10n-4.5.4.ebuild
new file mode 100644
index 000000000000..fde056b13bb3
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.5.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.5.4.ebuild,v 1.1 2010/12/02 21:14:32 alexxy Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-4.5.1.tar.bz2::' -e 's:kde-l10n-::' |tr '\n' ' '
+MY_LANGS="ar bg ca@valencia ca cs da de el en_GB eo es et eu fi fr fy ga gl gu
+he hi hr hu ia id is it ja kk km kn ko lt lv ml nb nds nl nn pa pl pt_BR pt ro
+ru sk sl sr sv th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}