summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-04-03 13:45:00 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-04-03 13:45:00 +0000
commit63aff86537d853ff03524f7a4a0638c8495c4066 (patch)
tree76f16e918f6a223f837d58a6a860e166b35b486d /kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-63aff86537d853ff03524f7a4a0638c8495c4066.tar.gz
gentoo-2-63aff86537d853ff03524f7a4a0638c8495c4066.tar.bz2
gentoo-2-63aff86537d853ff03524f7a4a0638c8495c4066.zip
Fix crash in Konqueror Ark plugin, KDE bug #113585.
(Portage version: 2.0.54)
Diffstat (limited to 'kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild')
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild b/kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild
new file mode 100644
index 000000000000..c73e0d7de78e
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.5.2-r1.ebuild,v 1.1 2006/04/03 13:45:00 carlo Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE addon modules: plugins for konqueror, noatun etc."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts berkdb sdl xmms"
+
+DEPEND="~kde-base/kdepim-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ ~kde-base/kdegames-${PV}
+ arts? ( ~kde-base/arts-${PV} )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ xmms? ( media-sound/xmms )
+ berkdb? ( || ( =sys-libs/db-4.3*
+ =sys-libs/db-4.2* ) )
+ !kde-misc/metabar"
+
+PATCHES="${FILESDIR}/konq-plugins-3.5.2-arkplugin-crash-fix.diff"
+
+src_compile() {
+ local myconf="$(use_with sdl) $(use_with xmms)"
+
+ if use berkdb; then
+ if has_version "=sys-libs/db-4.3*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.3
+ --with-extra-includes=/usr/include/db4.3"
+ elif has_version "=sys-libs/db-4.2*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.2
+ --with-extra-includes=/usr/include/db4.2"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}