summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-10-14 01:34:50 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-10-14 01:34:50 +0000
commit68208b9ba952abab319bfbcbe9011b814b6e8f60 (patch)
tree6021ce0615ac7da2ed788380ac7793afc08a94b0 /kde-base/kdeadmin/kdeadmin-3.3.1.ebuild
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-68208b9ba952abab319bfbcbe9011b814b6e8f60.tar.gz
gentoo-2-68208b9ba952abab319bfbcbe9011b814b6e8f60.tar.bz2
gentoo-2-68208b9ba952abab319bfbcbe9011b814b6e8f60.zip
Version bump
Diffstat (limited to 'kde-base/kdeadmin/kdeadmin-3.3.1.ebuild')
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/kdeadmin/kdeadmin-3.3.1.ebuild b/kde-base/kdeadmin/kdeadmin-3.3.1.ebuild
new file mode 100644
index 000000000000..202d9ab908e6
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.3.1.ebuild,v 1.1 2004/10/14 01:33:10 caleb Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~x86 ~amd64 ~ppc64 ~sparc ~ppc ~hppa"
+IUSE="pam"
+
+DEPEND="~kde-base/kdebase-${PV}
+ pam? ( >=sys-libs/pam-0.72 )"
+
+myconf="$myconf --without-rpm"
+DO_NOT_COMPILE="$DO_NOT_COMPILE kpackage ksysv"
+
+# we only want to compile the lilo config module on x86, but there we want to make sure it's
+# always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+# because configure when left to its own devices will build lilo-config or not basd on whether
+# lilo is present in the path.
+# so, we make configure build it by removing the configure.in.in file that checks for
+# lilo's presense
+src_unpack() {
+ kde_src_unpack
+ use x86 && echo > ${S}/lilo-config/configure.in.in
+}
+
+# TODO: add nis support