summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-08 15:49:59 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-08 15:49:59 +0000
commit830d221017749b6b8cbe494eb59002b170aa1841 (patch)
tree02b96a3efe5c144400987bd6bc665e21beeed88a /kde-base/kdebase/kdebase-3.2.0.ebuild
parentRemove old ebuilds. (diff)
downloadgentoo-2-830d221017749b6b8cbe494eb59002b170aa1841.tar.gz
gentoo-2-830d221017749b6b8cbe494eb59002b170aa1841.tar.bz2
gentoo-2-830d221017749b6b8cbe494eb59002b170aa1841.zip
Remove old ebuilds.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/kdebase/kdebase-3.2.0.ebuild')
-rw-r--r--kde-base/kdebase/kdebase-3.2.0.ebuild118
1 files changed, 0 insertions, 118 deletions
diff --git a/kde-base/kdebase/kdebase-3.2.0.ebuild b/kde-base/kdebase/kdebase-3.2.0.ebuild
deleted file mode 100644
index 1ba75a5a816a..000000000000
--- a/kde-base/kdebase/kdebase-3.2.0.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.2.0.ebuild,v 1.16 2005/01/17 15:41:51 danarmak Exp $
-
-inherit kde-dist eutils
-
-DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."
-
-KEYWORDS="x86 ppc sparc hppa amd64 alpha ia64"
-IUSE="ldap pam motif encode cups ssl opengl samba java"
-
-DEPEND="media-sound/cdparanoia
- ldap? ( net-nds/openldap )
- pam? ( sys-libs/pam )
- motif? ( x11-libs/openmotif )
- encode? ( media-sound/lame )
- cups? ( net-print/cups )
- ssl? ( dev-libs/openssl )
- opengl? ( virtual/opengl )
- samba? ( net-fs/samba )
- java? ( || ( virtual/jdk virtual/jre ) )
- >=media-libs/freetype-2"
-RDEPEND="${DEPEND}
- sys-apps/eject"
-
-src_unpack() {
- kde_src_unpack
- epatch ${FILESDIR}/${P}-kcontrol.patch
- cd ${S} && aclocal
-}
-
-src_compile() {
- myconf="$myconf --with-dpms --with-cdparanoia"
- myconf="$myconf `use_with ldap` `use_with motif`"
- myconf="$myconf `use_with encode lame` `use_with cups`"
- myconf="$myconf `use_with opengl gl` `use_with ssl`"
-
- if use java; then
- if [[ `has_version virtual/jdk` ]]; then
- myconf="$myconf --with-java=$(java-config --jdk-home)"
- else
- myconf="$myconf --with-java=$(java-config --jre-home)"
- fi
- else
- myconf="$myconf --without-java"
- fi
-
- use pam \
- && myconf="$myconf --with-pam=yes" \
- || myconf="$myconf --with-pam=no --with-shadow"
-
- kde_src_compile myconf configure
- kde_remove_flag kdm/kfrontend -fomit-frame-pointer
- kde_src_compile make
-}
-
-src_install() {
- kde_src_install
- cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup" install
-
- insinto /etc/pam.d
- newins ${FILESDIR}/kde.pam kde
- # kde-np is new requirement for 3.2 autologins - #33690
- newins ${FILESDIR}/kde-np.pam kde-np
-
- # startkde script
- cd ${D}/${KDEDIR}/bin
- epatch ${FILESDIR}/${PVR}/startkde-${PVR}-gentoo.diff
- mv startkde startkde.orig
- sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
- rm startkde.orig
- chmod a+x startkde
-
- # kcontrol modules
- cd ${D}/${KDEDIR}/etc/xdg/menus
- ln -s default_kde-settings.menu kde-settings.menu
- ln -s default_kde-information.menu kde-information.menu
- ln -s default_kde-screensavers.menu kde-screensavers.menu
-
- # x11 session script
- cd ${T}
- echo "#!/bin/sh
-${KDEDIR}/bin/startkde" > kde-${PV}
- chmod a+x kde-${PV}
- exeinto /etc/X11/Sessions
- doexe kde-${PV}
-
- cd ${D}/${KDEDIR}/share/config/kdm || die
- dodir ${KDEDIR}/share/config/kdm/sessions
- sed -e "s:_PREFIX_:${PREFIX}:g" \
- -e "s:_RANDOM_:${RANDOM}${RANDOM}:g" \
- ${FILESDIR}/${PVR}/kdmrc > kdmrc
- sed -e "s:_PREFIX_:${PREFIX}:g" ${FILESDIR}/${PVR}/Xsetup > Xsetup
-
- cp ${FILESDIR}/${PVR}/backgroundrc .
-
- #backup splashscreen images, so they can be put back when unmerging
- #mosfet or so.
- if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
- then
- cd ${D}/${KDEDIR}/share/apps
- cp -rf ksplash/ ksplash.default
- fi
-
- # Show gnome icons when choosing new icon for desktop shortcut
- dodir /usr/share/pixmaps
- mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
- rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
- cd ${D}/${KDEDIR}/share/apps/kdesktop/
- ln -sf /usr/share/pixmaps/ pics
-
- rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
-
-}
-
-pkg_postinst() {
- mkdir -p ${KDEDIR}/share/templates/.source/emptydir
-}