summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-02 17:08:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-02 17:08:23 +0000
commit645a6a48cd165c94cf33edbc6c2b858bcb36534d (patch)
tree56982169913daa4990704b8688bf70197414dcb9 /kde-base/kdebase
parentmedia-libs/libopendaap stable on ppc. (diff)
downloadgentoo-2-645a6a48cd165c94cf33edbc6c2b858bcb36534d.tar.gz
gentoo-2-645a6a48cd165c94cf33edbc6c2b858bcb36534d.tar.bz2
gentoo-2-645a6a48cd165c94cf33edbc6c2b858bcb36534d.zip
Adding a bit more of a patch to allow selection of alt-intl variant (by accepting the '-' in layout and variant name).
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/ChangeLog9
-rw-r--r--kde-base/kdebase/files/kxkb-3.5.0-modularxkb.patch17
2 files changed, 21 insertions, 5 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 667c71a379f4..a82936a9be9c 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdebase
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.247 2005/12/31 21:44:45 flameeyes Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.248 2006/01/02 17:08:23 flameeyes Exp $
+
+ 02 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ files/kxkb-3.5.0-modularxkb.patch:
+ Adding a bit more of a patch to allow selection of alt-intl variant (by
+ accepting the '-' in layout and variant name).
31 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+files/kcontrol-3.5.0-global-usbids.patch, kdebase-3.5.0-r1.ebuild:
diff --git a/kde-base/kdebase/files/kxkb-3.5.0-modularxkb.patch b/kde-base/kdebase/files/kxkb-3.5.0-modularxkb.patch
index f19bfd25f825..47eea8ee7efa 100644
--- a/kde-base/kdebase/files/kxkb-3.5.0-modularxkb.patch
+++ b/kde-base/kdebase/files/kxkb-3.5.0-modularxkb.patch
@@ -1,7 +1,7 @@
-Index: kxkb/rules.cpp
+Index: kdebase-3.5.0/kxkb/rules.cpp
===================================================================
---- kxkb/rules.cpp (revision 487566)
-+++ kxkb/rules.cpp (working copy)
+--- kdebase-3.5.0.orig/kxkb/rules.cpp
++++ kdebase-3.5.0/kxkb/rules.cpp
@@ -17,13 +17,13 @@
#include "rules.h"
@@ -18,3 +18,14 @@ Index: kxkb/rules.cpp
if( QDir(X11DirList[ii]).exists() ) {
X11_DIR = X11DirList[ii];
break;
+@@ -292,8 +292,8 @@ KeyRules::getVariants(const QString& lay
+
+ void KeyRules::parseVariants(const QStringList& vars, QDict<char>& variants, bool chkVars)
+ {
+- static const char* LAYOUT_PATTERN = "[a-z0-9_]*";
+- static const char* VARIANT_PATTERN = "\\([a-z0-9_]*\\)";
++ static const char* LAYOUT_PATTERN = "[a-z0-9_-]*";
++ static const char* VARIANT_PATTERN = "\\([a-z0-9_-]*\\)";
+ for (QStringList::ConstIterator it = vars.begin(); it != vars.end(); ++it)
+ {
+ QString varLine = (*it).stripWhiteSpace();