summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:34:43 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:34:43 +0000
commit1b534664aed76aa2c237c573fb6e86261e3c3314 (patch)
treeb00043f4b5eaaea9449b60469398de943704708a /kde-base/kdebindings-csharp
parentVersion bump KDE 4.4.3 (diff)
downloadgentoo-2-1b534664aed76aa2c237c573fb6e86261e3c3314.tar.gz
gentoo-2-1b534664aed76aa2c237c573fb6e86261e3c3314.tar.bz2
gentoo-2-1b534664aed76aa2c237c573fb6e86261e3c3314.zip
Version bump KDE 4.4.3
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdebindings-csharp')
-rw-r--r--kde-base/kdebindings-csharp/ChangeLog8
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/kdebindings-csharp/ChangeLog b/kde-base/kdebindings-csharp/ChangeLog
index 20eab58e3b9a..04dce95f6053 100644
--- a/kde-base/kdebindings-csharp/ChangeLog
+++ b/kde-base/kdebindings-csharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-csharp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.27 2010/03/31 22:21:28 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.28 2010/05/03 20:34:43 alexxy Exp $
+
+*kdebindings-csharp-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-csharp-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org>
-kdebindings-csharp-4.4.0.ebuild:
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild
new file mode 100644
index 000000000000..e793a7754b74
--- /dev/null
+++ b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild,v 1.1 2010/05/03 20:34:43 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="csharp"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta mono
+
+DESCRIPTION="C# bindings for KDE and Qt"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="akonadi +phonon plasma qimageblitz qscintilla semantic-desktop webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smoke 'akonadi?,phonon?,qimageblitz?,qscintilla?,semantic-desktop?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="smoke/"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.4.1-make-stuff-optional.patch )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+
+ if use plasma && ! use webkit; then
+ eerror
+ eerror "The plasma USE flag requires the webkit USE flag to be enabled."
+ eerror
+ eerror "Please enable webkit or disable plasma."
+ die "plasma requires webkit"
+ fi
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ # Disable soprano index (clucene) bindings
+ rm -f csharp/soprano/soprano/Soprano_Index_{CLuceneIndex,IndexFilterModel}.cs || die
+ sed -e 's/\${SOPRANO_INDEX_LIBRARIES}//g' \
+ -i csharp/soprano/CMakeLists.txt || die 'failed to remove clucene from link'
+
+ sed -e "/add_subdirectory( examples )/ s:^:#:" \
+ -i csharp/plasma/CMakeLists.txt || die 'failed to disable examples'
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_enable plasma PLASMA_SHARP)
+ $(cmake-utils_use_enable phonon PHONON_SHARP)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SHARP)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_SHARP)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SHARP)
+ )
+ kde4-meta_src_configure
+}