summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-12-12 01:02:11 +0000
committerJonathan Callen <abcd@gentoo.org>2011-12-12 01:02:11 +0000
commit0dc6a6b2a78a089ba9d316a4ea533fcc8df931e5 (patch)
treef8a52b80d555c4b545c454d688484e059b538a03 /kde-base/kdebindings-ruby
parentrm old files (diff)
downloadgentoo-2-0dc6a6b2a78a089ba9d316a4ea533fcc8df931e5.tar.gz
gentoo-2-0dc6a6b2a78a089ba9d316a4ea533fcc8df931e5.tar.bz2
gentoo-2-0dc6a6b2a78a089ba9d316a4ea533fcc8df931e5.zip
rm old files
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdebindings-ruby')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog6
-rw-r--r--kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch34
2 files changed, 5 insertions, 35 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
index 93d605774f28..bc0eac562874 100644
--- a/kde-base/kdebindings-ruby/ChangeLog
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdebindings-ruby
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.50 2011/08/15 21:24:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.51 2011/12/12 01:02:11 abcd Exp $
+
+ 12 Dec 2011; Jonathan Callen <abcd@gentoo.org>
+ -files/kdebindings-ruby-fix-linkage.patch:
+ rm old files
15 Aug 2011; Markus Meier <maekke@gentoo.org> kdebindings-ruby-4.6.5.ebuild:
x86 stable, bug #377465
diff --git a/kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch b/kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch
deleted file mode 100644
index 3e087ff1603f..000000000000
--- a/kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Unfortunately, it seems upstream hasn't added all the needed libraries for linking... fix that
-
---- kdebindings/ruby/qtscript/CMakeLists.txt
-+++ kdebindings/ruby/qtscript/CMakeLists.txt
-@@ -4,7 +4,7 @@
- set(qtscript_LIBRARY_SRC qtscript.cpp qtscripthandlers.cpp)
-
- add_library(qtscript MODULE ${qtscript_LIBRARY_SRC})
--target_link_libraries(qtscript ${QT_QTCORE_LIBRARY} ${RUBY_LIBRARY} smokeqtcore smokeqtscript qtruby4shared)
-+target_link_libraries(qtscript ${QT_QTCORE_LIBRARY} ${QT_QTSCRIPT_LIBRARY} ${RUBY_LIBRARY} smokeqtcore smokeqtscript qtruby4shared)
- set_target_properties(qtscript PROPERTIES PREFIX "")
- install(TARGETS qtscript DESTINATION ${CUSTOM_RUBY_SITE_ARCH_DIR})
- install(FILES qtscript.rb DESTINATION ${CUSTOM_RUBY_SITE_LIB_DIR}/qtscript)
---- kdebindings/ruby/soprano/CMakeLists.txt
-+++ kdebindings/ruby/soprano/CMakeLists.txt
-@@ -3,7 +3,7 @@
-
- set(rubysoprano_LIBRARY_SRC soprano.cpp sopranohandlers.cpp)
- add_library(rubysoprano MODULE ${rubysoprano_LIBRARY_SRC})
--target_link_libraries(rubysoprano ${QT_QTCORE_LIBRARY} ${RUBY_LIBRARY} smokeqtcore smokesoprano qtruby4shared)
-+target_link_libraries(rubysoprano ${QT_QTCORE_LIBRARY} ${RUBY_LIBRARY} ${SOPRANO_LIBRARIES} smokeqtcore smokesoprano qtruby4shared)
- set_target_properties(rubysoprano PROPERTIES PREFIX "" OUTPUT_NAME soprano)
- install(TARGETS rubysoprano DESTINATION ${CUSTOM_RUBY_SITE_ARCH_DIR})
- install(FILES soprano.rb DESTINATION ${CUSTOM_RUBY_SITE_LIB_DIR}/soprano)
---- kdebindings/ruby/nepomuk/CMakeLists.txt
-+++ kdebindings/ruby/nepomuk/CMakeLists.txt
-@@ -7,6 +7,7 @@
- target_link_libraries(rubynepomuk
- ${RUBY_LIBRARY}
- ${NEPOMUK_LIBRARIES}
-+ ${SOPRANO_LIBRARIES}
- smokeqtcore
- smokesoprano
- smokekdecore