summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-10-05 19:29:29 +0000
committerDan Armak <danarmak@gentoo.org>2002-10-05 19:29:29 +0000
commit9ba2d0eff6cfd61a67a101e8c293f39a44f202ae (patch)
treeefae01d07a7a57b57c6b35b1d56986ffc43cb587 /kde-base/kdegraphics
parentadded ppc to keywords (diff)
downloadgentoo-2-9ba2d0eff6cfd61a67a101e8c293f39a44f202ae.tar.gz
gentoo-2-9ba2d0eff6cfd61a67a101e8c293f39a44f202ae.tar.bz2
gentoo-2-9ba2d0eff6cfd61a67a101e8c293f39a44f202ae.zip
kde 3.0.4 ebuilds. 3.0.4 has NOT been released yet, don't try to use these, they are just for collaboration between me and verwilst.
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-3.0.41
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.0.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-3.0.4 b/kde-base/kdegraphics/files/digest-kdegraphics-3.0.4
new file mode 100644
index 000000000000..e2c39930d4ee
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-3.0.4
@@ -0,0 +1 @@
+MD5 6065219c825102c843ba582c4a520cac kdegraphics-3.0.4.tar.bz2 2665229
diff --git a/kde-base/kdegraphics/kdegraphics-3.0.4.ebuild b/kde-base/kdegraphics/kdegraphics-3.0.4.ebuild
new file mode 100644
index 000000000000..b85f32cd595e
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.0.4.ebuild,v 1.1 2002/10/05 19:29:29 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - graphics-related apps"
+
+KEYWORDS="x86"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 >=media-libs/libgpio-20010607 )
+ sys-devel/perl
+ scanner? ( media-gfx/sane-backends )
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib
+ app-text/ghostscript"
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+use scanner || KDE_REMOVE_DIR="kooka libkscan"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin "
+
+src_unpack() {
+
+ base_src_unpack
+
+ if [ -z "`use scanner`" ]; then
+ cd $S
+ mv Makefile.am Makefile.am.orig
+ sed -e 's:$(KSCANDIR)::' Makefile.am.orig > Makefile.am
+ fi
+
+} \ No newline at end of file