summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-01-05 13:09:43 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-01-05 13:09:43 +0000
commitdd5beffc3b870c1bdf440817ab3d12919081cdf1 (patch)
treee09058e9b40dce4dca811df1538345fe5e10f133 /kde-base/kdelibs
parentInitial Version (diff)
downloadgentoo-2-dd5beffc3b870c1bdf440817ab3d12919081cdf1.tar.gz
gentoo-2-dd5beffc3b870c1bdf440817ab3d12919081cdf1.tar.bz2
gentoo-2-dd5beffc3b870c1bdf440817ab3d12919081cdf1.zip
kde-3.1_rc6 :)
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1_rc61
-rw-r--r--kde-base/kdelibs/kdelibs-3.1_rc6.ebuild89
3 files changed, 96 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 4990fb39fba0..7f416eebbb1f 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.38 2003/01/05 01:51:02 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.39 2003/01/05 13:09:43 hannes Exp $
+
+*kdelibs-3.1_rc6 (05 Jan 2003)
+
+ 05 Jan 2003; Hannes Mehnert <hannes@gentoo.org> kdelibs-3.1_rc6.ebuild:
+ version bump
04 Jan 2003; Hannes Mehnert <hannes@gentoo.org> kdelibs-3.0.5a.ebuild:
included patch to have no crash if compiled with debug and clicking on
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1_rc6 b/kde-base/kdelibs/files/digest-kdelibs-3.1_rc6
new file mode 100644
index 000000000000..6d29bec96dca
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1_rc6
@@ -0,0 +1 @@
+MD5 38dc9210893543bd35be43d207f17409 kdelibs-3.1rc6.tar.bz2 10367519
diff --git a/kde-base/kdelibs/kdelibs-3.1_rc6.ebuild b/kde-base/kdelibs/kdelibs-3.1_rc6.ebuild
new file mode 100644
index 000000000000..517998ed0452
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1_rc6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1_rc6.ebuild,v 1.1 2003/01/05 13:09:43 hannes Exp $
+inherit kde kde.org flag-o-matic
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="~x86 ~sparc"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+S="$WORKDIR/${P//_}"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.1.0_rc6
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_compile() {
+
+ use alpha && append-flags -mieee
+ kde_src_compile myconf
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ [ "$ARCH" == "x86" ] && myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+KDEDIRS=${PREFIX}
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/49kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/56kdedir-${PV} # number goes up with version upgrade
+
+}
+
+