summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-11 13:38:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-11 13:38:28 +0000
commitd2e81745d303ac879bd47a2a50a9e001948edc61 (patch)
treef3df7bee50a209dc11e70b576a077fb24a7a81b9 /kde-base/kdenetwork
parentAdd patch to fix security bug #159658. (diff)
downloadgentoo-2-d2e81745d303ac879bd47a2a50a9e001948edc61.tar.gz
gentoo-2-d2e81745d303ac879bd47a2a50a9e001948edc61.tar.bz2
gentoo-2-d2e81745d303ac879bd47a2a50a9e001948edc61.zip
Add patch to fix security bug #159658.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'kde-base/kdenetwork')
-rw-r--r--kde-base/kdenetwork/ChangeLog10
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.5.5-r26
-rw-r--r--kde-base/kdenetwork/files/post-3.5.5-kdenetwork-ksirc.diff27
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.5-r2.ebuild90
4 files changed, 131 insertions, 2 deletions
diff --git a/kde-base/kdenetwork/ChangeLog b/kde-base/kdenetwork/ChangeLog
index b03b948ce13f..e87bf26e0078 100644
--- a/kde-base/kdenetwork/ChangeLog
+++ b/kde-base/kdenetwork/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdenetwork
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.235 2006/12/29 19:34:36 flameeyes Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.236 2007/01/11 13:38:28 flameeyes Exp $
+
+*kdenetwork-3.5.5-r2 (11 Jan 2007)
+
+ 11 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/post-3.5.5-kdenetwork-ksirc.diff, +kdenetwork-3.5.5-r2.ebuild:
+ Add patch to fix security bug #159658.
29 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/kdenetwork-3.5.5-linux-headers-2.6.18.patch,
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.5.5-r2 b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.5-r2
new file mode 100644
index 000000000000..e013575200c5
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.5-r2
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 a6e642c070cbd50d4a817f6588bf8e46 kdenetwork-3.5.5.tar.bz2 9235564
+RMD160 3e757d10ee5bf24b2ccf131e693fb614b9fdb9f4 kdenetwork-3.5.5.tar.bz2 9235564
+SHA256 c3f36e69bbd23902f2bdd9a1a8cda93b0436338ada422bb8ac6bc3d2bcd8e38f kdenetwork-3.5.5.tar.bz2 9235564
diff --git a/kde-base/kdenetwork/files/post-3.5.5-kdenetwork-ksirc.diff b/kde-base/kdenetwork/files/post-3.5.5-kdenetwork-ksirc.diff
new file mode 100644
index 000000000000..cd0b5699c94f
--- /dev/null
+++ b/kde-base/kdenetwork/files/post-3.5.5-kdenetwork-ksirc.diff
@@ -0,0 +1,27 @@
+--- ksirc/iocontroller.cpp
++++ ksirc/iocontroller.cpp
+@@ -237,7 +237,7 @@
+
+ if((line.length() > 0) && (line[0] == '~')){
+ pos3 = line.find('~', 1);
+- if(pos3 > 0){
++ if(pos3 > 1){
+ name = line.mid(1,pos3-1).lower();
+ name = name.lower();
+ line.remove(0, pos3+1);
+@@ -266,13 +266,13 @@
+ if(ksopts->autoCreateWin == TRUE && line[0] != '`' && line[1] != '#' && line[1] != '&' && noticeCreate) {
+ //kdDebug(5008) << "Creating window for: " << qsname << " because of: " << line.data() << endl;
+ ksircproc->new_toplevel(KSircChannel(ksircproc->serverName(), qsname));
+- assert(ksircproc->TopList[qsname] != 0x0);
+ }
+- else{
++ if (!ksircproc->TopList[qsname]) {
+ qsname = "!default";
+ if(line[0] == '`')
+ qsname = "!discard";
+ }
++ assert(ksircproc->TopList[qsname]);
+ }
+
+ ksircproc->TopList[qsname]->sirc_receive(line);
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.5-r2.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.5-r2.ebuild
new file mode 100644
index 000000000000..f38747d4951f
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.5.5-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.5-r2.ebuild,v 1.1 2007/01/11 13:38:28 flameeyes Exp $
+
+inherit kde-dist eutils flag-o-matic
+
+DESCRIPTION="KDE network applications: Kopete, KPPP, KGet,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jingle kdehiddenvisibility rdesktop sametime slp ssl wifi"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-1.0* )
+ slp? ( net-libs/openslp )
+ wifi? ( net-wireless/wireless-tools )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ rdesktop? ( >=net-misc/rdesktop-1.4.1 )
+ dev-lang/perl
+ ssl? ( dev-perl/IO-Socket-SSL
+ app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto
+ ) <virtual/x11-7 )
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/kopete-3.5.5-icqfix.patch
+ ${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch
+ ${FILESDIR}/post-3.5.5-kdenetwork-ksirc.diff"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+src_compile() {
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+
+ local myconf="--with-libidn
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi) $(use_enable jingle)
+ --without-xmms --without-external-libgadu"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # empty config file needed for lisa to work with default settings
+ dodir /etc
+ touch "${D}/etc/lisarc"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" "${WORKDIR}/patches/lisa" > "${T}/lisa"
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" "${WORKDIR}/patches/reslisa" > "${T}/reslisa"
+ exeinto /etc/init.d
+ doexe "${T}/lisa" "${T}/reslisa"
+
+ insinto /etc/conf.d
+ newins "${WORKDIR}/patches/lisa.conf" lisa
+ newins "${WORKDIR}/patches/reslisa.conf" reslisa
+}