summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-01 22:45:45 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-01 22:45:45 +0000
commitdc6063e1389a886c4bda996c0167242d414826cb (patch)
tree0c1e0754e44c8e19a67e7e406807397692389a24 /kde-base/kdepim-runtime
parentversion bump (diff)
downloadgentoo-2-dc6063e1389a886c4bda996c0167242d414826cb.tar.gz
gentoo-2-dc6063e1389a886c4bda996c0167242d414826cb.tar.bz2
gentoo-2-dc6063e1389a886c4bda996c0167242d414826cb.zip
Add upstream bugfixes
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog10
-rw-r--r--kde-base/kdepim-runtime/files/4.4/0001-Less-warnings-when-building-against-a-new-kdepimlibs.patch24
-rw-r--r--kde-base/kdepim-runtime/files/4.4/0002-Implement-readOnly-for-Akonadi-kresources.patch119
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r1.ebuild41
4 files changed, 193 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index f9a03c5c6b31..6671699ea592 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.83 2012/08/01 22:17:09 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.84 2012/08/01 22:45:45 dilfridge Exp $
+
+*kdepim-runtime-4.4.11.1-r1 (01 Aug 2012)
+
+ 01 Aug 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +files/4.4/0001-Less-warnings-when-building-against-a-new-kdepimlibs.patch,
+ +files/4.4/0002-Implement-readOnly-for-Akonadi-kresources.patch,
+ +kdepim-runtime-4.4.11.1-r1.ebuild:
+ Add upstream bugfixes
*kdepim-runtime-4.9.0 (01 Aug 2012)
diff --git a/kde-base/kdepim-runtime/files/4.4/0001-Less-warnings-when-building-against-a-new-kdepimlibs.patch b/kde-base/kdepim-runtime/files/4.4/0001-Less-warnings-when-building-against-a-new-kdepimlibs.patch
new file mode 100644
index 000000000000..662f38f17261
--- /dev/null
+++ b/kde-base/kdepim-runtime/files/4.4/0001-Less-warnings-when-building-against-a-new-kdepimlibs.patch
@@ -0,0 +1,24 @@
+From ab29b74fe8ec830c6d4c896900939c98d22c0e96 Mon Sep 17 00:00:00 2001
+From: Thomas McGuire <mcguire@kde.org>
+Date: Mon, 25 Apr 2011 00:36:43 +0100
+Subject: [PATCH 1/2] Less warnings when building against a new kdepimlibs.
+
+---
+ kresources/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/kresources/CMakeLists.txt b/kresources/CMakeLists.txt
+index 9fd1b37..a746796 100644
+--- a/kresources/CMakeLists.txt
++++ b/kresources/CMakeLists.txt
+@@ -1,4 +1,7 @@
+ add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
++add_definitions(-DWANT_DEPRECATED_KCAL_API)
++add_definitions(-DWANT_DEPRECATED_KABC_API)
++add_definitions(-DWANT_DEPRECATED_KRESOURCE_API)
+ include_directories (${kdepim-runtime_SOURCE_DIR} ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${KDE4_INCLUDES} ${QT_QTDBUS_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/shared)
+
+ # include (ConfigureChecks.cmake)
+--
+1.7.9.2
+
diff --git a/kde-base/kdepim-runtime/files/4.4/0002-Implement-readOnly-for-Akonadi-kresources.patch b/kde-base/kdepim-runtime/files/4.4/0002-Implement-readOnly-for-Akonadi-kresources.patch
new file mode 100644
index 000000000000..df3967cecf57
--- /dev/null
+++ b/kde-base/kdepim-runtime/files/4.4/0002-Implement-readOnly-for-Akonadi-kresources.patch
@@ -0,0 +1,119 @@
+From 8f85db2a32cab4bad987b2100424fbaf42f6ed26 Mon Sep 17 00:00:00 2001
+From: Thomas McGuire <mcguire@kde.org>
+Date: Mon, 25 Apr 2011 00:50:43 +0100
+Subject: [PATCH 2/2] Implement readOnly() for Akonadi kresources.
+
+Now it doesn't ask me if I want to save in my local calendar
+or in my Facebook folder anymore, since only the local calendar
+is writeable.
+
+REVIEW: 101229
+---
+ kresources/kabc/resourceakonadi.cpp | 5 +++++
+ kresources/kabc/resourceakonadi.h | 2 ++
+ kresources/kcal/resourceakonadi.cpp | 5 +++++
+ kresources/kcal/resourceakonadi.h | 2 ++
+ kresources/shared/sharedresourceprivate.h | 5 +++++
+ kresources/shared/subresourcemodel.h | 13 +++++++++++++
+ 6 files changed, 32 insertions(+)
+
+diff --git a/kresources/kabc/resourceakonadi.cpp b/kresources/kabc/resourceakonadi.cpp
+index d2ea349..39edf6e 100644
+--- a/kresources/kabc/resourceakonadi.cpp
++++ b/kresources/kabc/resourceakonadi.cpp
+@@ -249,5 +249,10 @@ void ResourceAkonadi::setSubresourceCompletionWeight( const QString &subResource
+ }
+ }
+
++bool ResourceAkonadi::readOnly() const
++{
++ return d->isReadOnly();
++}
++
+ #include "resourceakonadi.moc"
+ // kate: space-indent on; indent-width 2; replace-tabs on;
+diff --git a/kresources/kabc/resourceakonadi.h b/kresources/kabc/resourceakonadi.h
+index f2075a4..747a0c1 100644
+--- a/kresources/kabc/resourceakonadi.h
++++ b/kresources/kabc/resourceakonadi.h
+@@ -73,6 +73,8 @@ class ResourceAkonadi : public ResourceABC, public SharedResourceIface
+ virtual QStringList subresources() const;
+ virtual QMap<QString, QString> uidToResourceMap() const;
+
++ virtual bool readOnly() const;
++
+ StoreConfigIface &storeConfig();
+
+ public Q_SLOTS:
+diff --git a/kresources/kcal/resourceakonadi.cpp b/kresources/kcal/resourceakonadi.cpp
+index d2c9415..9552ffa 100644
+--- a/kresources/kcal/resourceakonadi.cpp
++++ b/kresources/kcal/resourceakonadi.cpp
+@@ -432,6 +432,11 @@ void ResourceAkonadi::doClose()
+ d->doClose();
+ }
+
++bool ResourceAkonadi::readOnly() const
++{
++ return d->isReadOnly();
++}
++
+ #include "resourceakonadi.moc"
+
+ // kate: space-indent on; indent-width 2; replace-tabs on;
+diff --git a/kresources/kcal/resourceakonadi.h b/kresources/kcal/resourceakonadi.h
+index a220616..f7ee77d 100644
+--- a/kresources/kcal/resourceakonadi.h
++++ b/kresources/kcal/resourceakonadi.h
+@@ -140,6 +140,8 @@ class ResourceAkonadi : public ResourceCalendar, public SharedResourceIface
+
+ virtual QString infoText() const;
+
++ virtual bool readOnly() const;
++
+ protected:
+ virtual bool doLoad( bool syncCache );
+
+diff --git a/kresources/shared/sharedresourceprivate.h b/kresources/shared/sharedresourceprivate.h
+index 8019204..ea551d5 100644
+--- a/kresources/shared/sharedresourceprivate.h
++++ b/kresources/shared/sharedresourceprivate.h
+@@ -68,6 +68,11 @@ class SharedResourcePrivate : public ResourcePrivateBase
+ return mModel.subResource( id );
+ }
+
++ bool isReadOnly() const
++ {
++ return !mModel.hasWritableSubResource();
++ }
++
+ protected:
+ SubResourceModelClass mModel;
+
+diff --git a/kresources/shared/subresourcemodel.h b/kresources/shared/subresourcemodel.h
+index b6f4dc2..956a0ff 100644
+--- a/kresources/shared/subresourcemodel.h
++++ b/kresources/shared/subresourcemodel.h
+@@ -97,6 +97,19 @@ class SubResourceModel : public AbstractSubResourceModel
+ return result;
+ }
+
++ bool hasWritableSubResource() const
++ {
++ Akonadi::MimeTypeChecker mimeChecker;
++ mimeChecker.setWantedMimeTypes( SubResourceClass::supportedMimeTypes() );
++
++ foreach ( const SubResourceClass *subResource, mSubResourcesByColId ) {
++ if ( subResource->isWritable() && mimeChecker.isWantedCollection( subResource->collection() ) ) {
++ return true;
++ }
++ }
++ return false;
++ }
++
+ SubResourceClass *findSubResourceForMappedItem( const QString &kresId ) const
+ {
+ foreach ( SubResourceClass *subResource, mSubResourcesByColId ) {
+--
+1.7.9.2
+
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r1.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r1.ebuild
new file mode 100644
index 000000000000..438f418ef44d
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r1.ebuild,v 1.1 2012/08/01 22:45:45 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} = *9999* ]]; then
+ KMNAME="kdepim"
+ KMMODULE="runtime"
+ inherit kde4-meta
+else
+ inherit kde4-base
+fi
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs
+
+COMMON_DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.3.1
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdelibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep libkdepim)
+ x11-misc/shared-mime-info
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+"
+
+add_blocker akonadi '<4.3.90'
+
+PATCHES=( "${FILESDIR}/4.4/"000[1-2]-*.patch )