summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-29 18:35:19 +0000
commite022af9e09a506be3fa71a44a9dacb94554ae3b0 (patch)
tree927f368d76846ba1fc8372e4a16b73202107d984 /kde-base/kdepim-runtime
parentfixing testing (diff)
downloadgentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.gz
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.tar.bz2
gentoo-2-e022af9e09a506be3fa71a44a9dacb94554ae3b0.zip
Version bump KDE SC 4.12.5
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog7
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.12.5.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 7805cf21a289..4063853e5d10 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.198 2014/04/22 22:23:34 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.199 2014/04/29 18:34:55 johu Exp $
+
+*kdepim-runtime-4.12.5 (29 Apr 2014)
+
+ 29 Apr 2014; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.12.5.ebuild:
+ Version bump KDE SC 4.12.5
22 Apr 2014; Johannes Huber <johu@gentoo.org> kdepim-runtime-4.13.0.ebuild:
Drop app-office/akonadi-server[soprano(-)], bug #508356.
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.12.5.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.12.5.ebuild
new file mode 100644
index 000000000000..49b96be0eac0
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.12.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.12.5.ebuild,v 1.1 2014/04/29 18:34:55 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.10.43[soprano(+)]
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}