summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 00:20:51 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 00:20:51 +0000
commit607fe70b656a8bf6042c83e5e021149a4e9553ad (patch)
tree0d201326a9cdbfc2cb109b4cd76335007a73d581 /kde-base/kdepimlibs
parentVersion bump KDE 4.3.0 (diff)
downloadgentoo-2-607fe70b656a8bf6042c83e5e021149a4e9553ad.tar.gz
gentoo-2-607fe70b656a8bf6042c83e5e021149a4e9553ad.tar.bz2
gentoo-2-607fe70b656a8bf6042c83e5e021149a4e9553ad.zip
Version bump KDE 4.3.0
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.3.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 9b84b59e5c71..72700abb756f 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.35 2009/06/22 04:36:03 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.36 2009/08/04 00:20:51 wired Exp $
+
+*kdepimlibs-4.3.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +kdepimlibs-4.3.0.ebuild:
+ Version bump
*kdepimlibs-4.2.4-r1 (22 Jun 2009)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.3.0.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.3.0.ebuild
new file mode 100644
index 000000000000..485269f47b9d
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.3.0.ebuild,v 1.1 2009/08/04 00:20:51 wired Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE="debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.2.0
+ dev-libs/boost
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.42
+ dev-libs/cyrus-sasl
+ ldap? ( net-nds/openldap )
+"
+# @since 4.3 - libkholidays is in kdepimlibs now
+RDEPEND="${DEPEND}
+ !kdeprefix? (
+ !kde-base/akonadi:4.1
+ !kde-base/libkholidays:4.1
+ !kde-base/libkholidays:4.2
+ )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)"
+
+ kde4-base_src_configure
+}