summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-22 04:36:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-22 04:36:03 +0000
commitbafb9f068c3f5c9fdf24720d4e7f4acae1e33872 (patch)
tree8756a0cfc6b41b63fbccd2242e8b9c7926f9c7d7 /kde-base/kdepimlibs
parentMarked ~hppa (bug #256063). (diff)
downloadgentoo-2-bafb9f068c3f5c9fdf24720d4e7f4acae1e33872.tar.gz
gentoo-2-bafb9f068c3f5c9fdf24720d4e7f4acae1e33872.tar.bz2
gentoo-2-bafb9f068c3f5c9fdf24720d4e7f4acae1e33872.zip
Fix support for app-crypt/gpgme-1.2.0 (bug #275006).
(Portage version: 13659-svn/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/files/kdepimlibs-4.2.4-gpgme-1.2.0.patch10
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.2.4-r1.ebuild42
3 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index a71c7346db31..9b84b59e5c71 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.34 2009/06/14 10:50:26 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.35 2009/06/22 04:36:03 arfrever Exp $
+
+*kdepimlibs-4.2.4-r1 (22 Jun 2009)
+
+ 22 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +kdepimlibs-4.2.4-r1.ebuild, +files/kdepimlibs-4.2.4-gpgme-1.2.0.patch:
+ Fix support for app-crypt/gpgme-1.2.0 (bug #275006).
14 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -kdepimlibs-4.2.3.ebuild:
Drop KDE 4.2.3
diff --git a/kde-base/kdepimlibs/files/kdepimlibs-4.2.4-gpgme-1.2.0.patch b/kde-base/kdepimlibs/files/kdepimlibs-4.2.4-gpgme-1.2.0.patch
new file mode 100644
index 000000000000..3b80ad6d09b8
--- /dev/null
+++ b/kde-base/kdepimlibs/files/kdepimlibs-4.2.4-gpgme-1.2.0.patch
@@ -0,0 +1,10 @@
+--- gpgme++/context.cpp
++++ gpgme++/context.cpp
+@@ -93,6 +93,7 @@
+ }
+
+ Context * Context::createForProtocol( Protocol proto ) {
++ gpgme_check_version ( NULL );
+ gpgme_ctx_t ctx = 0;
+ if ( gpgme_new ( &ctx ) != 0 )
+ return 0;
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.2.4-r1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.2.4-r1.ebuild
new file mode 100644
index 000000000000..b2f74c026684
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.2.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.2.4-r1.ebuild,v 1.1 2009/06/22 04:36:03 arfrever Exp $
+
+EAPI="2"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE="debug +handbook ldap +sasl"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.1
+ dev-libs/boost
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.33-r1
+ ldap? ( net-nds/openldap )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-base/akonadi:4.1 )
+"
+
+PATCHES=( "${FILESDIR}/${P}-gpgme-1.2.0.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap Ldap)
+ $(cmake-utils_use_with sasl Sasl2)"
+
+ kde4-base_src_configure
+}