summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
committerDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
commit80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4 (patch)
tree10350f32a739306558a2f194fa917fdb13a0e42c /kde-base/kdesktop/kdesktop-3.4.2.ebuild
parentMarked ~ppc. (diff)
downloadgentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.gz
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.bz2
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.zip
KDE 3.4.2 split ebuilds. p.masked, to be unmasked shortly.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base/kdesktop/kdesktop-3.4.2.ebuild')
-rw-r--r--kde-base/kdesktop/kdesktop-3.4.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-base/kdesktop/kdesktop-3.4.2.ebuild b/kde-base/kdesktop/kdesktop-3.4.2.ebuild
new file mode 100644
index 000000000000..b173134d5592
--- /dev/null
+++ b/kde-base/kdesktop/kdesktop-3.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.4.2.ebuild,v 1.1 2005/07/28 21:16:15 danarmak Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE desktop"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="$DEPEND
+$(deprange $PV $MAXKDEVER kde-base/libkonq)
+$(deprange $PV $MAXKDEVER kde-base/kdm)
+$(deprange $PV $MAXKDEVER kde-base/kcontrol)"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+$(deprange $PV $MAXKDEVER kde-base/kcheckpass)
+$(deprange 3.4.1 $MAXKDEVER kde-base/kdialog)"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+ libkonq/
+ kdm/kfrontend/themer/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+ kdmlib/"
+KMNODOCS=true
+
+src_install() {
+ # ugly, needs fixing: don't install kcontrol/background
+ kde-meta_src_install
+
+ rmdir ${D}/${PREFIX}/share/templates/.source/emptydir
+
+ # we install this script with kdialog, will not be needed in >=kde-3.4.2 (bug 89867)
+ rm ${D}/${PREFIX}/bin/kdeeject
+}
+
+pkg_postinst() {
+ mkdir -p ${PREFIX}/share/templates/.source/emptydir
+}