summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
commitb31cc0441f4628bad93065beae2d74cb436c08c6 (patch)
treeb946ea6b122ad7c1de4b8c58dc400606f74fb540 /kde-base/kimono
parentdev-libs/uriparser: 0.7.7 (diff)
downloadgentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.gz
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.bz2
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.zip
Version bump KDE SC 4.8.2
(Portage version: 2.2.0_alpha98/cvs/Linux i686)
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.8.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 809ddee7109f..540e0829d82e 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.20 2012/04/04 18:17:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.21 2012/04/04 23:59:08 johu Exp $
+
+*kimono-4.8.2 (04 Apr 2012)
+
+ 04 Apr 2012; Johannes Huber <johu@gentoo.org> +kimono-4.8.2.ebuild:
+ Version bump KDE SC 4.8.2
04 Apr 2012; Agostino Sarubbo <ago@gentoo.org> kimono-4.8.1.ebuild:
Stable for amd64, wrt bug #409403
diff --git a/kde-base/kimono/kimono-4.8.2.ebuild b/kde-base/kimono/kimono-4.8.2.ebuild
new file mode 100644
index 000000000000..911ddf34dca8
--- /dev/null
+++ b/kde-base/kimono/kimono-4.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.8.2.ebuild,v 1.1 2012/04/04 23:59:08 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'akonadi?,semantic-desktop=')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+ semantic-desktop? ( >=dev-libs/soprano-2.6.51[clucene] )
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}