summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-04-25 08:58:00 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-04-25 08:58:00 +0000
commit0f4c71d725d6d3d3d26ddb91124552af0180cb90 (patch)
tree91b836678b5ca42592fe47238db1271bd448f30f /kde-base/kmail
parent bump for utf8 encoding error from bug #174678 (diff)
downloadgentoo-2-0f4c71d725d6d3d3d26ddb91124552af0180cb90.tar.gz
gentoo-2-0f4c71d725d6d3d3d26ddb91124552af0180cb90.tar.bz2
gentoo-2-0f4c71d725d6d3d3d26ddb91124552af0180cb90.zip
bump for utf8 encoding error from bug #174678
(Portage version: 2.1.2.4)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/files/digest-kmail-3.5.5-r23
-rw-r--r--kde-base/kmail/kmail-3.5.5-r2.ebuild62
3 files changed, 71 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index f6c8e5ca1071..34e274e7b3fd 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.101 2007/04/24 16:57:31 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.102 2007/04/25 08:58:00 carlo Exp $
+
+*kmail-3.5.5-r2 (25 Apr 2007)
+
+ 25 Apr 2007; Carsten Lohrke <carlo@gentoo.org> +kmail-3.5.5-r2.ebuild:
+ bump for utf8 encoding error from bug #174678
*kmail-3.5.6-r3 (24 Apr 2007)
diff --git a/kde-base/kmail/files/digest-kmail-3.5.5-r2 b/kde-base/kmail/files/digest-kmail-3.5.5-r2
new file mode 100644
index 000000000000..a119724eb257
--- /dev/null
+++ b/kde-base/kmail/files/digest-kmail-3.5.5-r2
@@ -0,0 +1,3 @@
+MD5 3f2127f74cb496899bb3f1f6f702353b kdepim-3.5.5.tar.bz2 12908968
+RMD160 5bdcf98909f450ce3839fa72a404571f6cde22f6 kdepim-3.5.5.tar.bz2 12908968
+SHA256 82887df2c2ff00cb60dcfb8aa04527988123b9a4ed70f4c9082a7a0eb9f1f047 kdepim-3.5.5.tar.bz2 12908968
diff --git a/kde-base/kmail/kmail-3.5.5-r2.ebuild b/kde-base/kmail/kmail-3.5.5-r2.ebuild
new file mode 100644
index 000000000000..bdeba2bff10b
--- /dev/null
+++ b/kde-base/kmail/kmail-3.5.5-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.5-r2.ebuild,v 1.1 2007/04/25 08:58:00 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_DIR="${SRC_DIR}
+ mirror://gentoo/kdepim-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE mail client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+DEPEND="$(deprange 3.5.4 $MAXKDEVER kde-base/libkdenetwork)
+ $(deprange $PV $MAXKDEVER kde-base/libkdepim)
+ $(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+ $(deprange 3.5.4 $MAXKDEVER kde-base/mimelib)
+ $(deprange 3.5.0 $MAXKDEVER kde-base/libksieve)
+ $(deprange $PV $MAXKDEVER kde-base/certmanager)
+ $(deprange $PV $MAXKDEVER kde-base/libkcal)
+ $(deprange $PV $MAXKDEVER kde-base/kontact)
+ $(deprange 3.5.4 $MAXKDEVER kde-base/libkpgp)
+ $(deprange 3.5.3 $MAXKDEVER kde-base/libkmime)"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )
+ $(deprange $PV $MAXKDEVER kde-base/kdepim-kioslaves)
+ $(deprange $PV $MAXKDEVER kde-base/kmailcvt)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kdebase-kioslaves)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+ libkdepim libkdepim/
+ libkpimidentities libkpimidentities/
+ libmimelib mimelib/
+ libksieve libksieve/
+ libkleopatra certmanager/lib/
+ libkcal libkcal
+ libkpinterfaces kontact/interfaces/
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdenetwork/
+ libkdepim/
+ libkpimidentities/
+ libksieve/
+ libkcal/
+ mimelib/
+ certmanager/
+ korganizer/korganizeriface.h
+ kontact/interfaces/
+ libkmime/
+ libkpgp
+ dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="plugins/kmail/
+ kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+PATCHES="${FILESDIR}/${P}-dimap-mail-loss.patch
+ ${FILESDIR}/kmail-utf8.diff"