summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2006-03-22 20:15:49 +0000
committerDan Armak <danarmak@gentoo.org>2006-03-22 20:15:49 +0000
commit0979cc06b444f923bca22380a0a58f4a9b8ce2a4 (patch)
tree0f28cd6d7172f7619565520d1c2e67fcd733f729 /kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild
parentAdd ~amd64 keyword. Builds and runs as expected. (diff)
downloadgentoo-2-0979cc06b444f923bca22380a0a58f4a9b8ce2a4.tar.gz
gentoo-2-0979cc06b444f923bca22380a0a58f4a9b8ce2a4.tar.bz2
gentoo-2-0979cc06b444f923bca22380a0a58f4a9b8ce2a4.zip
KDE 3.5.2 - not yet released upstream, package.masked
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild')
-rw-r--r--kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild b/kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild
new file mode 100644
index 000000000000..91a661bafb3e
--- /dev/null
+++ b/kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konsolekalendar/konsolekalendar-3.5.2.ebuild,v 1.1 2006/03/22 20:15:35 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="A command line interface to KDE calendars"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)"
+
+
+KMCOPYLIB="libkcal libkcal
+ libkdepim libkdepim"
+KMEXTRACTONLY=" libkdepim/"
+KMCOMPILEONLY="libkcal"
+
+src_compile() {
+ export DO_NOT_COMPILE="libkcal"
+ kde-meta_src_compile myconf configure
+ cd $S/libkcal; make htmlexportsettings.h
+ kde-meta_src_compile make
+}