summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 12:55:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 12:55:07 +0000
commit041a68d4f370b1833315d92046942e7b1f76c4b8 (patch)
treece324acf135425c4f5027cb76e8284fb827c9324 /kde-base/kooka
parentMove myconf population in src_compile rather than global scope. (diff)
downloadgentoo-2-041a68d4f370b1833315d92046942e7b1f76c4b8.tar.gz
gentoo-2-041a68d4f370b1833315d92046942e7b1f76c4b8.tar.bz2
gentoo-2-041a68d4f370b1833315d92046942e7b1f76c4b8.zip
Move myconf population in src_compile rather than global scope.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'kde-base/kooka')
-rw-r--r--kde-base/kooka/ChangeLog6
-rw-r--r--kde-base/kooka/kooka-3.4.3.ebuild8
-rw-r--r--kde-base/kooka/kooka-3.5.2.ebuild9
-rw-r--r--kde-base/kooka/kooka-3.5.3.ebuild9
4 files changed, 23 insertions, 9 deletions
diff --git a/kde-base/kooka/ChangeLog b/kde-base/kooka/ChangeLog
index 92f39ad16438..da1ef0310da9 100644
--- a/kde-base/kooka/ChangeLog
+++ b/kde-base/kooka/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kooka
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/ChangeLog,v 1.48 2006/06/01 19:25:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/ChangeLog,v 1.49 2006/06/22 12:55:07 flameeyes Exp $
+
+ 22 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> kooka-3.4.3.ebuild,
+ kooka-3.5.2.ebuild, kooka-3.5.3.ebuild:
+ Move myconf population in src_compile rather than global scope.
*kooka-3.5.3 (01 Jun 2006)
diff --git a/kde-base/kooka/kooka-3.4.3.ebuild b/kde-base/kooka/kooka-3.4.3.ebuild
index 8f66a96450e1..db98ceabff68 100644
--- a/kde-base/kooka/kooka-3.4.3.ebuild
+++ b/kde-base/kooka/kooka-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.4.3.ebuild,v 1.9 2006/03/27 22:41:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.4.3.ebuild,v 1.10 2006/06/22 12:55:07 flameeyes Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -22,4 +22,8 @@ PATCHES1="${FILESDIR}/kdegraphics-3.4.1-gocr.patch"
# There's no ebuild for kadmos, and likely will never be since it isn't free.
PATCHES="$FILESDIR/configure-fix-kdegraphics-kadmos.patch"
-myconf="$myconf --without-kadmos"
+
+src_compile() {
+ myconf="$myconf --without-kadmos"
+ kde-meta_src_compile
+}
diff --git a/kde-base/kooka/kooka-3.5.2.ebuild b/kde-base/kooka/kooka-3.5.2.ebuild
index 7c0b3cec8966..61dcb3a37c22 100644
--- a/kde-base/kooka/kooka-3.5.2.ebuild
+++ b/kde-base/kooka/kooka-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.5.2.ebuild,v 1.8 2006/06/01 09:03:32 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.5.2.ebuild,v 1.9 2006/06/22 12:55:07 flameeyes Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -17,5 +17,8 @@ DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkscan)
KMCOPYLIB="libkscan libkscan"
KMEXTRACTONLY="libkscan"
-# There's no ebuild for kadmos, and likely will never be since it isn't free.
-myconf="$myconf --without-kadmos"
+src_compile() {
+ # There's no ebuild for kadmos, and likely will never be since it isn't free.
+ myconf="$myconf --without-kadmos"
+ kde-meta_src_compile
+}
diff --git a/kde-base/kooka/kooka-3.5.3.ebuild b/kde-base/kooka/kooka-3.5.3.ebuild
index 6417cda5e93d..3309c057ccc7 100644
--- a/kde-base/kooka/kooka-3.5.3.ebuild
+++ b/kde-base/kooka/kooka-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.5.3.ebuild,v 1.1 2006/06/01 19:25:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.5.3.ebuild,v 1.2 2006/06/22 12:55:07 flameeyes Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -17,5 +17,8 @@ DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkscan)
KMCOPYLIB="libkscan libkscan"
KMEXTRACTONLY="libkscan"
-# There's no ebuild for kadmos, and likely will never be since it isn't free.
-myconf="$myconf --without-kadmos"
+src_compile() {
+ # There's no ebuild for kadmos, and likely will never be since it isn't free.
+ myconf="$myconf --without-kadmos"
+ kde-meta_src_compile
+}