summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
commitc106175041331c114244227a14b1c3242fe799ee (patch)
treee16e2d4ee461b8ac893f1113d86a29e0b20658b8 /kde-base/korganizer
parentAdd patch to support >=gtk-2.24.0. #460714 (diff)
downloadgentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.gz
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.bz2
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.zip
Version bump KDE SC 4.10.2
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/korganizer')
-rw-r--r--kde-base/korganizer/ChangeLog8
-rw-r--r--kde-base/korganizer/korganizer-4.10.2.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/kde-base/korganizer/ChangeLog b/kde-base/korganizer/ChangeLog
index e12563dc7ef2..a4ebbca1af9c 100644
--- a/kde-base/korganizer/ChangeLog
+++ b/kde-base/korganizer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korganizer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/ChangeLog,v 1.264 2013/04/02 20:51:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/ChangeLog,v 1.265 2013/04/06 00:04:48 dilfridge Exp $
+
+*korganizer-4.10.2 (05 Apr 2013)
+
+ 05 Apr 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +korganizer-4.10.2.ebuild:
+ Version bump KDE SC 4.10.2
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> korganizer-4.10.1.ebuild:
Stable for ppc64, wrt to bug #462890
diff --git a/kde-base/korganizer/korganizer-4.10.2.ebuild b/kde-base/korganizer/korganizer-4.10.2.ebuild
new file mode 100644
index 000000000000..0ed2806b9711
--- /dev/null
+++ b/kde-base/korganizer/korganizer-4.10.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/korganizer-4.10.2.ebuild,v 1.1 2013/04/06 00:04:48 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="A Personal Organizer for KDE"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep kdepim-common-libs)
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep ktimezoned)
+"
+
+RESTRICT="test"
+# bug 393135
+
+KMLOADLIBS="kdepim-common-libs"
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarviews/
+ kdgantt2/
+ kmail/
+ pimcommon/
+ knode/org.kde.knode.xml
+ libkdepimdbusinterfaces/
+"
+
+KMCOMPILEONLY="
+ incidenceeditor-ng/
+ calendarsupport/
+"
+
+src_unpack() {
+ if use kontact; then
+ KMEXTRA="${KMEXTRA}
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_install() {
+ kde4-meta_src_install
+ # colliding with kdepim-common-libs
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendarplugin.desktop
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendardecoration.desktop
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}