summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
commitdaec5bb32d717672af35168b16bb8164f2533810 (patch)
tree64932fcb885be528a75e27b8edcfefe4903e17a0 /kde-base/korganizer
parentSwitch 9999 to truly live 'develop' branch per user request. (diff)
downloadgentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.gz
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.bz2
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.zip
Bump KDE SC 4.10.1
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7887F787)
Diffstat (limited to 'kde-base/korganizer')
-rw-r--r--kde-base/korganizer/ChangeLog8
-rw-r--r--kde-base/korganizer/korganizer-4.10.1.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/kde-base/korganizer/ChangeLog b/kde-base/korganizer/ChangeLog
index 9ad43d693c53..28d81ea98736 100644
--- a/kde-base/korganizer/ChangeLog
+++ b/kde-base/korganizer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korganizer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/ChangeLog,v 1.258 2013/02/23 16:49:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/ChangeLog,v 1.259 2013/03/06 13:41:42 dilfridge Exp $
+
+*korganizer-4.10.1 (06 Mar 2013)
+
+ 06 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +korganizer-4.10.1.ebuild:
+ Version bump KDE SC 4.10.1
23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> korganizer-4.10.0.ebuild,
korganizer-4.9.5.ebuild:
diff --git a/kde-base/korganizer/korganizer-4.10.1.ebuild b/kde-base/korganizer/korganizer-4.10.1.ebuild
new file mode 100644
index 000000000000..af16e0565663
--- /dev/null
+++ b/kde-base/korganizer/korganizer-4.10.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/korganizer-4.10.1.ebuild,v 1.1 2013/03/06 13:41:42 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="A Personal Organizer for KDE"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep kdepim-common-libs)
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep ktimezoned)
+"
+
+RESTRICT="test"
+# bug 393135
+
+KMLOADLIBS="kdepim-common-libs"
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarviews/
+ kdgantt2/
+ kmail/
+ pimcommon/
+ knode/org.kde.knode.xml
+ libkdepimdbusinterfaces/
+"
+
+KMCOMPILEONLY="
+ incidenceeditor-ng/
+ calendarsupport/
+"
+
+src_unpack() {
+ if use kontact; then
+ KMEXTRA="${KMEXTRA}
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_install() {
+ kde4-meta_src_install
+ # colliding with kdepim-common-libs
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendarplugin.desktop
+ rm -rf "${ED}"/usr/share/kde4/servicetypes/calendardecoration.desktop
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}