summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:14:32 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:14:32 +0000
commita583eb83f12cbbd80998c8da58e1bdcd9841da3a (patch)
tree3a0ab6ea3c05c277897b631d316fccb5a7dc116f /kde-base/korundum
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-a583eb83f12cbbd80998c8da58e1bdcd9841da3a.tar.gz
gentoo-2-a583eb83f12cbbd80998c8da58e1bdcd9841da3a.tar.bz2
gentoo-2-a583eb83f12cbbd80998c8da58e1bdcd9841da3a.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog8
-rw-r--r--kde-base/korundum/korundum-3.5.9.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 8a9ccdecc12e..cd05b2db0831 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.70 2008/02/17 03:17:54 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.71 2008/02/20 23:14:32 philantrop Exp $
+
+*korundum-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +korundum-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
17 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -korundum-3.5.5.ebuild,
-korundum-3.5.6.ebuild, -korundum-3.5.7.ebuild:
diff --git a/kde-base/korundum/korundum-3.5.9.ebuild b/kde-base/korundum/korundum-3.5.9.ebuild
new file mode 100644
index 000000000000..9f67f5d9b31a
--- /dev/null
+++ b/kde-base/korundum/korundum-3.5.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-3.5.9.ebuild,v 1.1 2008/02/20 23:14:32 philantrop Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt libsmokekde smoke/kde"
+KMCOMPILEONLY="qtruby"
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="KDE ruby bindings"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+OLDDEPEND=">=virtual/ruby-1.8 ~kde-base/qtruby-$PV ~kde-base/smoke-3.3.1"
+DEPEND=">=virtual/ruby-1.8
+>=kde-base/qtruby-${PV}:${SLOT}
+>=kde-base/smoke-${PV}:${SLOT}"
+RDEPEND="${DEPEND}"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke and qtruby versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}