summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 19:56:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 19:56:25 +0000
commitd84171364487624c804fd46cf3eb02767e1d618c (patch)
tree69d2a8c25f2ac193cbdaee9b7236aa8427b78f53 /kde-base/kpilot
parentVersion bump KDE 4.3.2 (diff)
downloadgentoo-2-d84171364487624c804fd46cf3eb02767e1d618c.tar.gz
gentoo-2-d84171364487624c804fd46cf3eb02767e1d618c.tar.bz2
gentoo-2-d84171364487624c804fd46cf3eb02767e1d618c.zip
Version bump KDE 4.3.2
(Portage version: 2.2_rc44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog7
-rw-r--r--kde-base/kpilot/kpilot-4.3.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index 2f0889e5bf3f..1d83c0ba61b3 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.91 2009/09/01 15:49:57 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.92 2009/10/06 19:56:25 alexxy Exp $
+
+*kpilot-4.3.2 (06 Oct 2009)
+
+ 06 Oct 2009; Alexey Shvetsov <alexxy@gentoo.org> +kpilot-4.3.2.ebuild:
+ Version bump
*kpilot-4.3.1 (01 Sep 2009)
diff --git a/kde-base/kpilot/kpilot-4.3.2.ebuild b/kde-base/kpilot/kpilot-4.3.2.ebuild
new file mode 100644
index 000000000000..42242178eec9
--- /dev/null
+++ b/kde-base/kpilot/kpilot-4.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-4.3.2.ebuild,v 1.1 2009/10/06 19:56:25 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KPilot is software for syncing PalmOS based handhelds."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="avantgo crypt debug +handbook"
+
+DEPEND="
+ >=app-pda/pilot-link-0.12
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+ avantgo? ( >=dev-libs/libmal-0.40 )
+ crypt? ( app-crypt/qca:2 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with avantgo Mal)
+ $(cmake-utils_use_with crypt QCA2)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test (as of 4.2.87)
+ sed -i -e '/keyringcategorysynctest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/conduits/keyringconduit/tests/CMakeLists.txt || \
+ die "sed to disable keyringcategorysynctest failed."
+
+ kde4-meta_src_test
+}