summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 12:03:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 12:03:42 +0000
commit505b28b73e316587aed855e0b3e41f584d3009f7 (patch)
tree20a999d88b3adf69cc97b9e0fd8b51f1f28aec2e /kde-base/kscd/kscd-3.5.5.ebuild
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-505b28b73e316587aed855e0b3e41f584d3009f7.tar.gz
gentoo-2-505b28b73e316587aed855e0b3e41f584d3009f7.tar.bz2
gentoo-2-505b28b73e316587aed855e0b3e41f584d3009f7.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/kscd/kscd-3.5.5.ebuild')
-rw-r--r--kde-base/kscd/kscd-3.5.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/kscd/kscd-3.5.5.ebuild b/kde-base/kscd/kscd-3.5.5.ebuild
new file mode 100644
index 000000000000..4b790851aac6
--- /dev/null
+++ b/kde-base/kscd/kscd-3.5.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kscd/kscd-3.5.5.ebuild,v 1.1 2006/10/03 12:03:42 flameeyes Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdemultimedia-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE CD player"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkcddb)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="libkcddb libkcddb"
+KMEXTRACTONLY="
+ mpeglib_artsplug/configure.in.in"
+
+KMCOMPILEONLY="libkcddb"
+
+src_compile() {
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile myconf configure
+ cd $S/libkcddb && make configbase.h
+ cd $S/libkcddb && make cdinfodialogbase.h
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile make
+}