summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-23 01:19:25 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-23 01:19:25 +0000
commitd77a9ade78fa25a526ac1e9d80cc68974004bd0b (patch)
tree5c026d8b2fea969600c282bb76b6e3ffa78b8287 /kde-base/kscd/kscd-3.5.7.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d77a9ade78fa25a526ac1e9d80cc68974004bd0b.tar.gz
gentoo-2-d77a9ade78fa25a526ac1e9d80cc68974004bd0b.tar.bz2
gentoo-2-d77a9ade78fa25a526ac1e9d80cc68974004bd0b.zip
Version bump.
(Portage version: 2.1.2.7)
Diffstat (limited to 'kde-base/kscd/kscd-3.5.7.ebuild')
-rw-r--r--kde-base/kscd/kscd-3.5.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/kscd/kscd-3.5.7.ebuild b/kde-base/kscd/kscd-3.5.7.ebuild
new file mode 100644
index 000000000000..0f1602f6e966
--- /dev/null
+++ b/kde-base/kscd/kscd-3.5.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kscd/kscd-3.5.7.ebuild,v 1.1 2007/05/23 01:19:25 carlo Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}"
+
+DESCRIPTION="KDE CD player"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkcddb)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="libkcddb libkcddb"
+
+KMCOMPILEONLY="libkcddb"
+
+PATCHES="${FILESDIR}/${P}-alsa-tests.patch ${FILESDIR}/${P}-arts.patch"
+
+src_compile() {
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile myconf configure
+ cd $S/libkcddb && make configbase.h
+ cd $S/libkcddb && make cdinfodialogbase.h
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile make
+}