summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-10 23:52:50 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-10 23:52:50 +0000
commitd46faae9e0876aa70823f55ff73d890656b0a360 (patch)
tree24648be6f5a68de16ade4e59f7ec44bb2b934097 /kde-base/ksplash
parentVersion bump to KDE 4.0.2. (diff)
downloadgentoo-2-d46faae9e0876aa70823f55ff73d890656b0a360.tar.gz
gentoo-2-d46faae9e0876aa70823f55ff73d890656b0a360.tar.bz2
gentoo-2-d46faae9e0876aa70823f55ff73d890656b0a360.zip
Version bump to KDE 4.0.2.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog8
-rw-r--r--kde-base/ksplash/ksplash-4.0.2.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 2f0140b1dd1f..419ad0cce94f 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.4 2008/02/17 01:52:50 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.5 2008/03/10 23:52:50 philantrop Exp $
+
+*ksplash-4.0.2 (10 Mar 2008)
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +ksplash-4.0.2.ebuild:
+ Version bump to KDE 4.0.2
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -ksplash-4.0.0.ebuild:
Spring cleaning
diff --git a/kde-base/ksplash/ksplash-4.0.2.ebuild b/kde-base/ksplash/ksplash-4.0.2.ebuild
new file mode 100644
index 000000000000..20c8ec67c41c
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.0.2.ebuild,v 1.1 2008/03/10 23:52:50 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+ kde4-meta_src_compile
+}