summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
committerJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
commit2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51 (patch)
tree733e9e1acf77d4f47af78826e93c8cf4d670bf27 /kde-base/kstars
parentFix LICENSE, bug 447390. (diff)
downloadgentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.gz
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.bz2
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.zip
Version bump KDE SC 4.10.3.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, RepoMan options: --include-arches="amd64", signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.10.3.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 901644e3803a..d5890d0b6f31 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.270 2013/05/05 11:50:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.271 2013/05/06 20:18:04 johu Exp $
+
+*kstars-4.10.3 (06 May 2013)
+
+ 06 May 2013; Johannes Huber <johu@gentoo.org> +kstars-4.10.3.ebuild:
+ Version bump KDE SC 4.10.3
05 May 2013; Agostino Sarubbo <ago@gentoo.org> -kstars-4.10.1.ebuild:
Remove old
diff --git a/kde-base/kstars/kstars-4.10.3.ebuild b/kde-base/kstars/kstars-4.10.3.ebuild
new file mode 100644
index 000000000000..4f074f46b8ae
--- /dev/null
+++ b/kde-base/kstars/kstars-4.10.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.10.3.ebuild,v 1.1 2013/05/06 20:18:04 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug fits indi"
+
+DEPEND="
+ dev-cpp/eigen:2
+ $(add_kdebase_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.9.1 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-base_src_configure
+}