summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
commit20f55f8fb805f8021dd9ded690b2815eb78ffc4f (patch)
tree80067b7b6ce35f4bffa5921e939a528f7d1cae22 /kde-base/ksystemlog
parentVersion bump. (diff)
downloadgentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.gz
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.bz2
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.zip
Version bump KDE SC 4.10.4
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.10.4.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 060fdc6a85c9..0708f8e7e44c 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.153 2013/06/04 13:06:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.154 2013/06/04 18:21:56 johu Exp $
+
+*ksystemlog-4.10.4 (04 Jun 2013)
+
+ 04 Jun 2013; Johannes Huber <johu@gentoo.org> +ksystemlog-4.10.4.ebuild:
+ Version bump KDE SC 4.10.4
04 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ksystemlog-4.10.3.ebuild:
Stable for amd64, wrt to bug #471392
diff --git a/kde-base/ksystemlog/ksystemlog-4.10.4.ebuild b/kde-base/ksystemlog/ksystemlog-4.10.4.ebuild
new file mode 100644
index 000000000000..e79e47e95f19
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.10.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.10.4.ebuild,v 1.1 2013/06/04 18:21:56 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+KDE_SCM="svn"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}