summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/ksystemlog
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.8.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 943d68b82d46..39d0558fe5d7 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.97 2012/01/17 13:29:03 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.98 2012/01/25 18:17:01 johu Exp $
+
+*ksystemlog-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +ksystemlog-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> -ksystemlog-4.7.3.ebuild:
Remove KDE SC 4.7.3
diff --git a/kde-base/ksystemlog/ksystemlog-4.8.0.ebuild b/kde-base/ksystemlog/ksystemlog-4.8.0.ebuild
new file mode 100644
index 000000000000..93b27d024279
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.8.0.ebuild,v 1.1 2012/01/25 18:17:01 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}