summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commitb55417d98c3ac6be2310a3971632cceac43c9378 (patch)
tree76ff040300cffb0bfdb60a4c1a785df48fbbf7cd /kde-base/ksystemlog
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadgentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.gz
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.bz2
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.zip
[kde-base] Add KDE SC 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.6.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 86f0833731fa..87f4057cefcb 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.63 2011/01/10 11:53:42 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.64 2011/01/26 20:28:49 alexxy Exp $
+
+*ksystemlog-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksystemlog-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*ksystemlog-4.5.5 (10 Jan 2011)
diff --git a/kde-base/ksystemlog/ksystemlog-4.6.0.ebuild b/kde-base/ksystemlog/ksystemlog-4.6.0.ebuild
new file mode 100644
index 000000000000..c8e739bcbff8
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.6.0.ebuild,v 1.1 2011/01/26 20:28:49 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+
+inherit virtualx kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+ fi
+}
+
+src_test() {
+ export maketype="kde4-meta_src_test"
+ virtualmake
+}