summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-04-17 18:52:27 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-04-17 18:52:27 +0000
commit78a9e9c8079bf87c35ef7aba507ba64780468168 (patch)
treeb53a0ae4ab9ec13eed353279e696fc3ff56fb253 /kde-base/kwin/kwin-3.5.2-r2.ebuild
parentReplace -O2 and -O3 with -O1 to avoid miscompilation, thanks to kenzelma in b... (diff)
downloadgentoo-2-78a9e9c8079bf87c35ef7aba507ba64780468168.tar.gz
gentoo-2-78a9e9c8079bf87c35ef7aba507ba64780468168.tar.bz2
gentoo-2-78a9e9c8079bf87c35ef7aba507ba64780468168.zip
Updated patch to fix bug #127980 and #128379.
(Portage version: 2.0.54)
Diffstat (limited to 'kde-base/kwin/kwin-3.5.2-r2.ebuild')
-rw-r--r--kde-base/kwin/kwin-3.5.2-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/kwin/kwin-3.5.2-r2.ebuild b/kde-base/kwin/kwin-3.5.2-r2.ebuild
new file mode 100644
index 000000000000..c5781bc85902
--- /dev/null
+++ b/kde-base/kwin/kwin-3.5.2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.2-r2.ebuild,v 1.1 2006/04/17 18:52:27 carlo Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xcomposite"
+RDEPEND="xcomposite? ( || ( (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ ) <=x11-base/xorg-x11-6.9 )
+ )"
+DEPEND="${RDEPEND}
+ xcomposite? ( || ( (
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ ) <=x11-base/xorg-x11-6.9 )
+ )"
+
+PATCHES="${FILESDIR}/kwin-3.5.2-alt_tab_and_focus_chain_fix.diff"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}