summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commitb0cf2ebbfc7626d65b374788654d4e26028bda3f (patch)
tree473933e2eaf30d14938b24846be4b834a0d385d4 /kde-base/okular
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadgentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.gz
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.bz2
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.zip
Version bump to KDE 4.0.1.
(Portage version: 2.1.4.1)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/okular-4.0.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/kde-base/okular/okular-4.0.1.ebuild b/kde-base/okular/okular-4.0.1.ebuild
new file mode 100644
index 000000000000..830f4ad68391
--- /dev/null
+++ b/kde-base/okular/okular-4.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.0.1.ebuild,v 1.1 2008/02/07 00:12:56 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdegraphics
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~x86"
+IUSE="chm debug djvu htmlhandbook jpeg pdf tiff"
+
+RDEPEND=">=app-text/libspectre-0.2
+ media-libs/freetype
+ kde-base/qimageblitz
+ chm? ( app-doc/chmlib )
+ djvu? ( >=app-text/djvu-3.5.17 )
+ jpeg? ( media-libs/jpeg )
+ pdf? ( >=app-text/poppler-0.5.4
+ >=app-text/poppler-bindings-0.5.4 )
+ tiff? ( media-libs/tiff )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/${KMNAME}-${PV}-system-libspectre.patch"
+
+pkg_setup() {
+ if use pdf; then
+ KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
+ app-text/poppler-bindings qt4"
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ # remove internal copy of libspectre
+ rm -r "${S}"/okular/generators/spectre/libspectre || \
+ die "Failed to remove internal copy of libspectre."
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with chm CHM)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with jpeg JPEG)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff TIFF)"
+
+ kde4-meta_src_compile
+}