summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
commit3f801aa646c6bf1e1d60d310da2302c2bd9fef66 (patch)
tree6e50112a7a8405c97655dde74a1c9e8217de71bd /kde-base/perlqt
parentremove old (diff)
downloadgentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.gz
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.bz2
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.zip
[kde-base] Add KDE SC 4.14.3
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.14.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 29f95c0d5a4b..4cb6d57f360b 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.157 2014/11/14 19:33:13 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.158 2014/11/16 12:21:31 alexxy Exp $
+
+*perlqt-4.14.3 (16 Nov 2014)
+
+ 16 Nov 2014; Alexey Shvetsov <alexxy@gentoo.org> +perlqt-4.14.3.ebuild:
+ Version bump KDE SC 4.14.3
14 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -perlqt-4.13.3.ebuild,
-perlqt-4.14.1.ebuild:
diff --git a/kde-base/perlqt/perlqt-4.14.3.ebuild b/kde-base/perlqt/perlqt-4.14.3.ebuild
new file mode 100644
index 000000000000..34fe551a7c13
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.14.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.14.3.ebuild,v 1.1 2014/11/16 12:21:31 alexxy Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.80-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${BUILD_DIR}/blib/arch:${BUILD_DIR}/blib/lib" kde4-base_src_test
+}