summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-23 18:43:44 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-23 18:43:44 +0000
commit35c4a8120bc7f23bb96ede3d3c4277c523aaabbf (patch)
treea19c8d6be3620e7604568d35ae4f16a96d87511c /kde-base/phonon-kde
parentamd64/x86 stable, bug #264346 (diff)
downloadgentoo-2-35c4a8120bc7f23bb96ede3d3c4277c523aaabbf.tar.gz
gentoo-2-35c4a8120bc7f23bb96ede3d3c4277c523aaabbf.tar.bz2
gentoo-2-35c4a8120bc7f23bb96ede3d3c4277c523aaabbf.zip
Pulled update phonon-kde from the kde-testing overlay - thanks to Maciej Mrozowski (reavertm) <reavertm@poczta.fm>.
Fixed automagic from bug 266968 + some other (Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog10
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.2.2-r1.ebuild45
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 97274ecd4bb2..43a81fab46d4 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.12 2009/04/17 06:40:41 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.13 2009/04/23 18:43:44 jmbsvicetto Exp $
+
+*phonon-kde-4.2.2-r1 (23 Apr 2009)
+
+ 23 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +phonon-kde-4.2.2-r1.ebuild:
+ Pulled update phonon-kde from the kde-testing overlay. Original ChangeLog
+ entry: 21 Apr 2009; Maciej Mrozowski (reavertm) <reavertm@poczta.fm> Fixed
+ automagic from bug 266968 + some other
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> -phonon-kde-4.2.1.ebuild,
phonon-kde-4.2.2:
diff --git a/kde-base/phonon-kde/phonon-kde-4.2.2-r1.ebuild b/kde-base/phonon-kde/phonon-kde-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..0ce609a409bb
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.2.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.2.2-r1.ebuild,v 1.1 2009/04/23 18:43:44 jmbsvicetto Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="debug pulseaudio +xine"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-sound/phonon[xine?]
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-base/phonon-xine[-kdeprefix] )
+"
+
+src_prepare() {
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+ # Disable automagic
+ sed -e 's/find_package(Xine)/macro_optional_find_package(Xine)/' \
+ -i phonon/kcm/xine/CMakeLists.txt || die "Failed to make xine optional"
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ $(cmake-utils_use_with xine Xine)"
+
+ kde4-meta_src_configure
+}