summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:24:15 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:24:15 +0000
commit3899c0f70fc2aa6fe8d5520c634427864bca2f2b (patch)
tree29d8a6bbe6d48134d9e426f351f7a031d46f8fda /kde-base/phonon-kde
parentVersion bump KDE 4.3.1 (diff)
downloadgentoo-2-3899c0f70fc2aa6fe8d5520c634427864bca2f2b.tar.gz
gentoo-2-3899c0f70fc2aa6fe8d5520c634427864bca2f2b.tar.bz2
gentoo-2-3899c0f70fc2aa6fe8d5520c634427864bca2f2b.zip
Version bump KDE 4.3.1
(Portage version: 2.2_rc38/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.3.1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 1229af7cec0f..720550361db8 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.22 2009/08/04 04:45:29 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.23 2009/09/01 16:24:15 tampakrap Exp $
+
+*phonon-kde-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +phonon-kde-4.3.1.ebuild:
+ Version bump
04 Aug 2009; Alex Alexander <wired@gentoo.org> ChangeLog:
manifest update (upstream tarball changed)
diff --git a/kde-base/phonon-kde/phonon-kde-4.3.1.ebuild b/kde-base/phonon-kde/phonon-kde-4.3.1.ebuild
new file mode 100644
index 000000000000..4be128f5e58c
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.3.1.ebuild,v 1.1 2009/09/01 16:24:15 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="debug pulseaudio +xine"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-sound/phonon[xine?]
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-base/phonon-xine[-kdeprefix] )
+"
+
+src_prepare() {
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+ # Disable automagic
+ sed -e 's/find_package(Xine)/macro_optional_find_package(Xine)/' \
+ -i phonon/kcm/xine/CMakeLists.txt || die "Failed to make xine optional"
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ $(cmake-utils_use_with xine)"
+
+ kde4-meta_src_configure
+}