summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:44:10 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:44:10 +0000
commit8f9c1eaf2ce3a5a3b94e2907836a6688209b701c (patch)
tree5f13f01ddf3f29d52b320afa371c9249bf33e18a /kde-base/phonon
parentAdded the KDE 4.0.5 version of parley. (diff)
downloadgentoo-2-8f9c1eaf2ce3a5a3b94e2907836a6688209b701c.tar.gz
gentoo-2-8f9c1eaf2ce3a5a3b94e2907836a6688209b701c.tar.bz2
gentoo-2-8f9c1eaf2ce3a5a3b94e2907836a6688209b701c.zip
Added the KDE 4.0.5 version of phonon.
(Portage version: 2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'kde-base/phonon')
-rw-r--r--kde-base/phonon/ChangeLog7
-rw-r--r--kde-base/phonon/phonon-4.0.5.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/phonon/ChangeLog b/kde-base/phonon/ChangeLog
index bf4983076a79..b13e8ebd18a4 100644
--- a/kde-base/phonon/ChangeLog
+++ b/kde-base/phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon/ChangeLog,v 1.8 2008/05/30 08:36:43 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon/ChangeLog,v 1.9 2008/06/05 22:44:10 keytoaster Exp $
+
+*phonon-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org> +phonon-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of phonon.
30 May 2008; Bo Ørsted Andresen <zlin@gentoo.org> phonon-4.0.4.ebuild:
KDE4_BUILT_WITH_USE_CHECK is now always an array. Bug #216863.
diff --git a/kde-base/phonon/phonon-4.0.5.ebuild b/kde-base/phonon/phonon-4.0.5.ebuild
new file mode 100644
index 000000000000..92a1cb3d0e7e
--- /dev/null
+++ b/kde-base/phonon/phonon-4.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon/phonon-4.0.5.ebuild,v 1.1 2008/06/05 22:44:10 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-runtime
+KMMODULE=phonon
+inherit kde4-meta
+
+DESCRIPTION="KDE multimedia API"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug xcb"
+
+# There's currently only a xine backend for phonon available,
+# a gstreamer backend from TrollTech is in the works.
+DEPEND=">=media-libs/xine-lib-1.1.9
+ xcb? ( x11-libs/libxcb )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use xcb; then
+ KDE4_BUILT_WITH_USE_CHECK=("media-libs/xine-lib xcb")
+ fi
+
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with xcb XCB)
+ -DWITH_Xine=ON"
+
+ kde4-meta_src_compile
+}