summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-06-30 01:07:23 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-06-30 01:07:23 +0000
commitf08b1287ac05733b47c493183f3425c3150d0675 (patch)
tree2f9fae3dead9c898edba53129d987744b5687b6c /kde-base/pykde4/files
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-f08b1287ac05733b47c493183f3425c3150d0675.tar.gz
gentoo-2-f08b1287ac05733b47c493183f3425c3150d0675.tar.bz2
gentoo-2-f08b1287ac05733b47c493183f3425c3150d0675.zip
Add patch fixing compilation on ARM, bug 322351
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/pykde4/files')
-rw-r--r--kde-base/pykde4/files/pykde4-4.4.4-arm-sip.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/kde-base/pykde4/files/pykde4-4.4.4-arm-sip.patch b/kde-base/pykde4/files/pykde4-4.4.4-arm-sip.patch
new file mode 100644
index 000000000000..f967c451e7df
--- /dev/null
+++ b/kde-base/pykde4/files/pykde4-4.4.4-arm-sip.patch
@@ -0,0 +1,22 @@
+diff -Naur pykde4-4.4.3.orig/python/pykde4/CMakeLists.txt pykde4-4.4.3/python/pykde4/CMakeLists.txt
+--- pykde4-4.4.3.orig/python/pykde4/CMakeLists.txt 2010-03-29 14:57:40.000000000 +0200
++++ pykde4-4.4.3/python/pykde4/CMakeLists.txt 2010-05-31 15:49:17.095615617 +0200
+@@ -75,6 +75,9 @@
+ ${KDEPIMLIBS_INCLUDE_DIRS}
+ )
+
++# Pull in ARM configuration options if needed
++STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
++
+ SET(SIP_INCLUDES ${PYQT4_SIP_DIR} sip)
+ SET(SIP_CONCAT_PARTS 8)
+ IF (WIN32)
+@@ -82,7 +85,7 @@
+ ELSE (WIN32)
+ SET(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
+ ENDIF (WIN32)
+-SET(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
++SET(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
+
+ # Use an extra option when compiling on Python 3.
+ IF (PYTHON_3)