summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
commit461c1af9ab4c8cfbdc911a491f7c86af2ef043dd (patch)
tree05608ce8b58bb6826c888fa542fb8c351b8e650b /kde-base/qtruby
parentUse QA_PREBUILT, fix minor QA issues, wrt bug #430026 (diff)
downloadgentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.gz
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.bz2
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.zip
Version bump KDE SC 4.9.5
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog9
-rw-r--r--kde-base/qtruby/qtruby-4.9.5.ebuild74
2 files changed, 81 insertions, 2 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index a0178932d3bf..9404edd09243 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qtruby
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.133 2012/12/26 10:46:34 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.134 2013/01/05 20:18:36 creffett Exp $
+
+*qtruby-4.9.5 (05 Jan 2013)
+
+ 05 Jan 2013; <creffett@gentoo.org> +qtruby-4.9.5.ebuild:
+ Version bump KDE SC 4.9.5
26 Dec 2012; Markus Meier <maekke@gentoo.org> qtruby-4.9.4.ebuild:
add ~arm
diff --git a/kde-base/qtruby/qtruby-4.9.5.ebuild b/kde-base/qtruby/qtruby-4.9.5.ebuild
new file mode 100644
index 000000000000..72d9e7055f04
--- /dev/null
+++ b/kde-base/qtruby/qtruby-4.9.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.9.5.ebuild,v 1.1 2013/01/05 20:18:36 creffett Exp $
+
+EAPI=4
+
+OPENGL_REQUIRED="always"
+DECLARATIVE_REQUIRED="optional"
+KDE_REQUIRED="never"
+USE_RUBY="ruby18"
+# No ruby19 for three reasons:
+# 1) it does not build (yet) - will likely be solved soon
+# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="Qt Ruby bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qscintilla qwt webkit"
+
+DEPEND="
+ $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
+"
+
+RDEPEND="${DEPEND}
+"
+
+# Split from kdebindings-ruby in 4.7
+add_blocker kdebindings-ruby
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ local CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}