summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:35:25 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:35:25 +0000
commit680969aeaadabbd2fab306f6c9900e5b4d919153 (patch)
treea7819e727c3b763300a6437049920aa000d12ecf /kde-base/quanta/quanta-3.5.9.ebuild
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-680969aeaadabbd2fab306f6c9900e5b4d919153.tar.gz
gentoo-2-680969aeaadabbd2fab306f6c9900e5b4d919153.tar.bz2
gentoo-2-680969aeaadabbd2fab306f6c9900e5b4d919153.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/quanta/quanta-3.5.9.ebuild')
-rw-r--r--kde-base/quanta/quanta-3.5.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/quanta/quanta-3.5.9.ebuild b/kde-base/quanta/quanta-3.5.9.ebuild
new file mode 100644
index 000000000000..10f284c920f3
--- /dev/null
+++ b/kde-base/quanta/quanta-3.5.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.5.9.ebuild,v 1.1 2008/02/20 23:35:25 philantrop Exp $
+KMNAME=kdewebdev
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc kdehiddenvisibility"
+
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${RDEPEND}
+ doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+ kde-meta_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ echo
+ elog "${P} has some optional dependencies which you might want to emerge:"
+ elog "- app-text/htmltidy for HTML syntax checking."
+ elog "- app-crypt/gnupg for previewing browser configuration."
+ elog "- kde-base/kompare for comparing files by content."
+ elog "- kde-base/cervisia for enabling the CVS management plugin."
+ elog "- kde-base/kfilereplace for searching and replacing in files."
+ elog "- kde-base/kimagemapeditor for editing HTML image maps."
+ elog "- kde-base/klinkstatus for link validity checking."
+ elog "- kde-base/kxsldbg for XSLT debugging."
+ elog "- kde-base/kommander for the QuickStart dialogue and other scripted dialogues."
+ echo
+}