summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
commit3d71d92c727066f449accc1c2b7461faade152ef (patch)
tree76c3626fcc383e0dea8d20c1bf208a6e28044206 /kde-base/qyoto
parentupdated HOMEPAGE to http://www.ugetdm.com (diff)
downloadgentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.gz
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.bz2
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.zip
Version bump KDE SC 4.11.3
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.11.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 04ee4f94b29b..65e7285af4f5 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.88 2013/10/10 01:27:19 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.89 2013/11/05 22:22:41 dilfridge Exp $
+
+*qyoto-4.11.3 (05 Nov 2013)
+
+ 05 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org> +qyoto-4.11.3.ebuild:
+ Version bump KDE SC 4.11.3
10 Oct 2013; Chris Reffett <creffett@gentoo.org> -qyoto-4.11.1.ebuild:
Drop KDE SC 4.11.1
diff --git a/kde-base/qyoto/qyoto-4.11.3.ebuild b/kde-base/qyoto/qyoto-4.11.3.ebuild
new file mode 100644
index 000000000000..476bd5892784
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.11.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.11.3.ebuild,v 1.1 2013/11/05 22:22:41 dilfridge Exp $
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}