summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3 (patch)
treeacda1b1644e123ebe3d9623addcce4017adb629d /kde-base/smokeqt
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadgentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.gz
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.tar.bz2
gentoo-2-401c3e3183c60a1db08e8b751d4e9f8e7a3dc5b3.zip
Version bump KDE SC 4.9.0
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog7
-rw-r--r--kde-base/smokeqt/smokeqt-4.9.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index 1589ea94d7fd..332d6ecf9eb6 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.28 2012/06/21 21:54:31 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.29 2012/08/01 22:16:51 johu Exp $
+
+*smokeqt-4.9.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +smokeqt-4.9.0.ebuild:
+ Version bump KDE SC 4.9.0
*smokeqt-4.8.4 (21 Jun 2012)
diff --git a/kde-base/smokeqt/smokeqt-4.9.0.ebuild b/kde-base/smokeqt/smokeqt-4.9.0.ebuild
new file mode 100644
index 000000000000..b68ddef7a26f
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.9.0.ebuild,v 1.1 2012/08/01 22:16:51 johu Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+KDE_SCM="git"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-test:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( x11-libs/qt-webkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}