summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
commitc106175041331c114244227a14b1c3242fe799ee (patch)
treee16e2d4ee461b8ac893f1113d86a29e0b20658b8 /kde-base/smokeqt
parentAdd patch to support >=gtk-2.24.0. #460714 (diff)
downloadgentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.gz
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.bz2
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.zip
Version bump KDE SC 4.10.2
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog8
-rw-r--r--kde-base/smokeqt/smokeqt-4.10.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index 3c3ed95b6969..ada2cb257f5a 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.63 2013/04/02 20:51:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.64 2013/04/06 00:03:59 dilfridge Exp $
+
+*smokeqt-4.10.2 (05 Apr 2013)
+
+ 05 Apr 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +smokeqt-4.10.2.ebuild:
+ Version bump KDE SC 4.10.2
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> smokeqt-4.10.1.ebuild:
Stable for ppc64, wrt to bug #462890
diff --git a/kde-base/smokeqt/smokeqt-4.10.2.ebuild b/kde-base/smokeqt/smokeqt-4.10.2.ebuild
new file mode 100644
index 000000000000..952cccdce48c
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.10.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.10.2.ebuild,v 1.1 2013/04/06 00:03:59 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qttest:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}